Help get this topic noticed by sharing it on Twitter, Facebook, or email.

OpenVPN won't connect to VPN Cubed Manager

I have my VPN cubed manager working in one subnet of an Amazon VPC. I can successfully connect to it with a site to site vpn. Now I want to add the overlay network, so I installed OpenVPN on a machine in a subnet in the VPC, installed the client pack and tried both the public IP and the private IP address of the VPN cubed manager in the config file. But whenever I start OpenVPN the icon just goes from red to yellow, I never get a green icon indicating that I have a vpn connection. The system is Windows Server 2008 SP2, and I tried the registry patch listed in the instructions.
Here is the output from the OpenVPN GUI, I removed my public IP and replaced with :

Tue Nov 15 19:16:49 2011 OpenVPN 2.2.1 Win32-MSVC++ [SSL] [LZO2] built on Jul 1 2011
Tue Nov 15 19:16:49 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Nov 15 19:16:49 2011 LZO compression initialized
Tue Nov 15 19:16:49 2011 UDPv4 link local: [undef]
Tue Nov 15 19:16:49 2011 UDPv4 link remote: :1194
Tue Nov 15 19:17:50 2011 [UNDEF] Inactivity timeout (--ping-restart), restarting
Tue Nov 15 19:17:50 2011 SIGUSR1[soft,ping-restart] received, process restarting
Tue Nov 15 19:18:00 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Nov 15 19:18:00 2011 Re-using SSL/TLS context
Tue Nov 15 19:18:00 2011 LZO compression initialized
Tue Nov 15 19:18:00 2011 UDPv4 link local: [undef]
Tue Nov 15 19:18:00 2011 UDPv4 link remote: :1194
Tue Nov 15 19:19:01 2011 [UNDEF] Inactivity timeout (--ping-restart), restarting
Tue Nov 15 19:19:01 2011 SIGUSR1[soft,ping-restart] received, process restarting
Tue Nov 15 19:19:11 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Nov 15 19:19:11 2011 Re-using SSL/TLS context
Tue Nov 15 19:19:11 2011 LZO compression initialized
Tue Nov 15 19:19:11 2011 UDPv4 link local: [undef]
Tue Nov 15 19:19:11 2011 UDPv4 link remote: :1194
1 person has
this problem
+1
Reply
  • Something is not right.

    In your log, the line "UDPv4 link remote: :1194" indicates that your config file is somehow missing the "remote" line - if that line were there the log should say "remote: ip_address:1194". Please review our docs and double check that you didn't miss any steps.

    Also, could you please try to downgrade to OpenVPN 2.1 - I think we have had more success with 2.1.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m thankful
    Dmitriy,

    Thanks for the response. I found my problem, I had to add a rule to the security group for the VPN Cubed Manager to allow inbound connections on UDP 1194, your example for setting up the security group on page 12 did not list this port as a requirement in the documentation.
    My remote line was correct, I just removed my public IP address when I posted the file.
    Thanks for your assistance.
    Dave
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated