Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

Tomcat doesn't start on Virtual Image.

Tomcat doesn't start on Virtual Image. It's configured with Razuna. I can reach the "Elastic Server Manager" page and I can see that Tomcat service is not running.
I tried to start Tomcat with the start link, and it seems to be running, but it don't.
If I click the Refresh link in the "Elastic Server Manager" page, I see that Tomcat is "Stopped".

When checking the catalina_2011-02-11.log
I see the following..

Quote:
Using CATALINA_BASE: /var/lib/tomcat6.0
Using CATALINA_HOME: /usr/share/tomcat6.0
Using CATALINA_TMPDIR: /var/lib/tomcat6.0/temp
Using JRE_HOME: /opt/java
Error occurred during initialization of VM
Could not reserve enough space for object heap
Error occurred during initialization of VM
Could not reserve enough space for object heap
Error occurred during initialization of VM
Could not reserve enough space for object heap

I looks like a problem with Java...
I downloaded this elastic server "RAZUNA_NGINX_MYSQL"
And I'm trying to run in on osx 10.6.6 within a vmware fusion 3.0.0 environment.

How can I start Tomcat?

If you need more info let me know.

Thanks

Christian
1 person has
this problem
+1
Reply
  • Hi,

    Can you provide the URL of the server you built or downloaded?

    Cheers,

    Pat K
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Christian,

    Thank you for your patience. The problem that your seeing is due (as the cryptic error message said) to a lack of memory. Tomcat has been set up to require a heap size of a minimum of 1024MB (1GB). The machine you've downloaded has only 512MB of memory (and a 512MB swap image).

    The easiest solution is to modify the amount of memory in the image.

    In VMware Fusion, select the image in the Virtual Machine Library, click on the Settings button, choose Processors & RAM and modify the RAM size.

    I was able to get Tomcat running with 1.5GB of RAM (1536MB).

    The marginally more difficult approach (or, at least, less safe) is to modify the Catalina environment variables. To do this, logon as cftuser. Then type the following:

        sudo vi /usr/share/tomcat6.0/bin/setenv.sh

    Change the values of the -Xms and -Xmx options. I used:

        -Xms128m -Xmx256m

    Save the file, then try to start Tomcat. Doing this I was able to start Tomcat in a machine that only had 512MB of RAM.

    Hope this helps.

    Nicholas
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m smiling
    I got it to work.. first of all by just increasing the memory of the VM second by editing the variables as mentioned.

    Don't know if its related but sometimes the pictures uploaded don't get added to the library. Did not troubleshoot it properly (also don't know exactly how) but at first hand it looks like the vm is running out of memory and therefore doesn't add the images.

    The razuna vm i'm using now needs at least around 1GB of ram to function proparly.

    I downloaded the VM here:
    https://elasticserver.com/server/2628...
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited