No sound on some channels

  • Question
  • Updated 10 months ago
I currently have Comcast cable. I went to turn on my TV last night and some channels had sound and some didn't. I tried it on another TV in my house and had the same issue so I know it's not the tv but the cable. Any suggestion on how to fix this?
Photo of Noelle

Noelle

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 33
Photo of ComcastCares1

ComcastCares1, Employee

  • 631 Posts
  • 30 Reply Likes
We apologize for the trouble. We will definitely look into this for you. Will you please send us the phone number associated with the account?
Regards,
Mark Casem
Comcast Corp.
National Customer Operation
We_Can_Help@cable.comcast.com
Photo of Tommy Wilkerson

Tommy Wilkerson

  • 1 Post
  • 0 Reply Likes
Wow that was it just hit the language button on the comcast remote
Photo of Renee Wilson Quaranta

Renee Wilson Quaranta

  • 1 Post
  • 0 Reply Likes
OMG!!!! havent had volume for six months on my favorite station. came upon this feed and waa-laa!!! hit the language button. I seriously can not believe that is all it took. Thank you, thank you, thank you. I was going to go buy a new TV. :)
Photo of Kelly Finney

Kelly Finney

  • 1 Post
  • 0 Reply Likes
Yeah it worked for me too!!! Can't believe it!!!
Photo of Januel Stephens

Januel Stephens

  • 1 Post
  • 0 Reply Likes
Thank you!! It worked!!
Photo of Almira Acevedo

Almira Acevedo

  • 1 Post
  • 0 Reply Likes
Wow that's crazy! It worked for me too I had been without sound on some channels for 3 days now! The "lang" button did make it work!
Photo of gubry

gubry

  • 1 Post
  • 0 Reply Likes
734 459 0794
Photo of farmy fields

farmy fields

  • 1 Post
  • 11 Reply Likes
if you have a DTA hooked up to that TV, you just need to hit the "lang" button on the comcast remote. That should restore audio.
Photo of Sue Ogle

Sue Ogle

  • 1 Post
  • 0 Reply Likes
Thank you thank you. I just hit LANG button, and mine worked, too!!! I'd been trying to figure out why I had sound on some channels and not others for weeks!!!
Photo of Trish McLoughlin

Trish McLoughlin

  • 1 Post
  • 0 Reply Likes
Awesome! Lang button...who woulda thought! Thanks!
Photo of Bryan

Bryan

  • 1 Post
  • 0 Reply Likes
my 8 year old had me rolling on the floor after we fixed it with the "LANG" button thanks to YOU ALL! she said "OH, it must have been on SIGN LANGUAGE" ROFLMAO!
Photo of Wanda Bain

Wanda Bain

  • 1 Post
  • 0 Reply Likes
thanks guys, I now can watch my channel in the
bedroom that was not having sound..go figure
Photo of Eli

Eli

  • 3 Posts
  • 0 Reply Likes
Thanks "LANG" did it. Must have rolled over that little button when I fell asleep.LOL
Photo of donald province

donald province

  • 2 Posts
  • 0 Reply Likes
I have the exact same problem. Do not have a DTA hookup. At least I don't think so.....
Photo of Ellen Fields

Ellen Fields

  • 1 Post
  • 0 Reply Likes
Then it is SAP
Photo of Matthew Henrick

Matthew Henrick

  • 1 Post
  • 0 Reply Likes
SAP did it for me and I have Brighthouse cable in Fl. I moved it from mono to stereo. Problem solved !!!!
Photo of crazydazyz

crazydazyz

  • 1 Post
  • 0 Reply Likes
I have the same problem with about 200 apartments full of old people. This is so frustrating. AND I also am having some people who are hearing the audio, but seeing no picture. Why can't it just work?
Photo of hthr_byron

hthr_byron

  • 1 Post
  • 0 Reply Likes
I have this same problem. It makes no sense at all. I have no cable boxes or surround sound or any other auxillaries. Just cable to the tv. Some channels are fine, but there are about 5-6 that have picture and no sound. It's driving me crazy.
Photo of paradise.biz.news

paradise.biz.news

  • 2 Posts
  • 3 Reply Likes
Posted 12/31/2009

Same problem here which I only noticed about 2 weeks ago (but it could have been going on much longer because we seldom watch channels other than one or two channels).

But when I went channel surfing thru all channels a few weeks ago, these four specific channels no longer have audio:
58 - AMTV
46 - TNT
42 - Nick@Nite
31 - USA

We've had Comcast cable since June 1, 2009, and all worked fine for months. We have no special or fancy equipment, just the simple cable cord attached to the TV which was set up and hooked up by the comcast installers back on June 1, and nothing has been changed nor altered since that day.
So what's the deal, Comcast, with the No Audio on the above four channels?
Photo of Timothy

Timothy

  • 1 Post
  • 2 Reply Likes
Try going to Menu on your TV then go to the Audio section then try switching around your audio settings. Remember to write how they are in the first place.

Hope this helped.
Photo of Haz

Haz

  • 1 Post
  • 0 Reply Likes
Thanks, Timothy: Your easy tip did the trick! We had a similar problem. with our 13" Magnavox flat panel TV w/basic Comcast, and no Comcast handheld. Suddenly we didn't get sound on Channel 2 (all other channels OK). After reading your suggestion, I noticed the MTS/SAP button on the Magnavox controller. Depressed it a couple of times and ... voila ... SOUND! Thanks so much for sharing!
Photo of martha rees

martha rees

  • 1 Post
  • 0 Reply Likes
No DTA, just comcast cable box. No sound on some channels. No 'lang' button. TV audio button settings switched (balance, etc.), but it didn't work. THx
Photo of Jennifer Blachly

Jennifer Blachly

  • 1 Post
  • 0 Reply Likes
Thanks so much Haz. The MTS/SAP button did the trick for me. You rock!
Photo of Carlton

Carlton

  • 2 Posts
  • 0 Reply Likes
On my GE RM24918/RM84918 Universal Remote, the Angle button near the bottom of the remote changed the language setting, while in the 'cable' mode. It doesn't 'punch through' in other modes, so you have to push the 'cable' (CBL/SAT) button, first - but it did set the language on my Comcast Digital Transport Adapter (DTA), which is the smaller box that they give you when you have multiple televisions, but don't want to pay for multiple receivers. (I think that the difference is that it doesn't do Pay-Per-View.)

Pushing the Angle button appears to scroll through however many language options are available (just the two, for me). Just push and release it until you see "ENG".

It's likely that this will work on other remotes as well. I did look at some of the others in my home, and not all have a button to do this, at all. My GE 24997/24998 appears to lack this functionality, for example. While that probably means that I can't screw up the language setting with this remote, to need to fix it - it does suggest an interesting prank to pull on people using third-party-manufacturer universal remotes... ;-p
Photo of paradise.biz.news

paradise.biz.news

  • 2 Posts
  • 3 Reply Likes
Well, Timothy, you are a genius! Thank you! I confess that when I first saw your response, I didn't believe it, lol. But sure enough, if ANY channel is on the "SAP" Audio Mode, there is NO Sound! (I have no idea what SAP means - Silent Audio _____ maybe?). But switching it to MONO or STEREO Audio options & Voila! The sound returns!! HA! = laughing at myself that the solution was so simple! Duh on me! I thought I would never get to watch Law & Order again since it airs on 31 and 46 and 58, three of the four channels that I thought had lost audio permanently. Lol, just too funny.

Thanks again, Timothy, for making my day!
Photo of Kenan Branam

Kenan Branam

  • 2 Posts
  • 0 Reply Likes
My Toshiba has a SAP on/off. It's on now and every channel works now. Thank you, thank you!
Photo of bhorner2

bhorner2

  • 3 Posts
  • 0 Reply Likes
I also had a Toshiba and was having the same problem. Basic comcast cable but no handheld. I just went to menu button on my remote and switched the audio's MTS option to mono or stereo and i could hear every channel! But as soon as I switch it back to SAP, no sound. So glad I googled this problem! Thanks guys! Much relief! :)
Photo of bhorner2

bhorner2

  • 3 Posts
  • 0 Reply Likes
I also had a Toshiba and was having the same problem. Basic comcast cable but no handheld. I just went to menu button on my remote and switched the audio's MTS option to mono or stereo and i could hear every channel! But as soon as I switch it back to SAP, no sound. So glad I googled this problem! Thanks guys! Much relief! :)
Photo of clyowell52

clyowell52

  • 1 Post
  • 0 Reply Likes
couldn't believe it--came home and every other channel had no sound---tried this with moving away from SAP and all sound returned...now wonder who set it to the SAP??? Thanks!! Came right to the computer to find the solution instead of calling anyone else!
Photo of Brad Shumate

Brad Shumate

  • 1 Post
  • 0 Reply Likes
Had this problem too. Don't know what a DTA is but i hit the LANG button on the remote anyways and it fixed it.
Photo of Brighid

Brighid

  • 1 Post
  • 1 Reply Like
I also just hit "lang" and it was fixed. It seemed to change it from a Spanish dub, back to English. It appears that any channel without a Spanish dub just comes in silent and a couple just buzz...I guess the feature isn't as multilingual friendly as was first intended?
Photo of numnum2794

numnum2794

  • 1 Post
  • 0 Reply Likes
omg lang works. I just pressed the button and yayyy! thank you timothy
Photo of Dave and Rich

Dave and Rich

  • 1 Post
  • 0 Reply Likes
Amazing. This just happened to us, here on Cape Cod. This leads to several questions:

1. Why isn't that button recessed?
2. Why is that button so close to the frequently used Chanel button?
3. Why doesn't Comcast know about this problem when the whole internet seems to be aware of it?
4. Think of all of the gas and time spent by repair people all over the country going to residences and businesses that could be saved. Not very green.
Photo of ric gorski

ric gorski

  • 1 Post
  • 1 Reply Like
OMG, this thing called the internet is great ! Missed two David Garrett concerts on PBS, then searched the prob and found the answer here, just hit the lang button and , SOUND ! Thanks so much !
Photo of NickyD

NickyD

  • 1 Post
  • 1 Reply Like
It worked for me too. Thanks. Nicky D in Roswell, GA
Photo of moore.kellen

moore.kellen

  • 1 Post
  • 0 Reply Likes
Yeah Timothy owns, Lang button worked for me
Photo of citydiner1

citydiner1

  • 1 Post
  • 0 Reply Likes
Thank you...thank you...thank you! Why can't all of life's problems be fixed with the push of a button? I'm too embarrassed to tell you how long I lived with the silent channel. I even used the radio when watching a football game to get the sound. Next time life hands me lemons, I'm pressing the Lang button to make lemonade!
Photo of Shirley Haverstock

Shirley Haverstock

  • 1 Post
  • 0 Reply Likes
This solution worked right away! Thanks a million. I had one channel with picture but no sojund. Just pushed the Lang button and instant sound.
Photo of karen.parker2

karen.parker2

  • 1 Post
  • 0 Reply Likes
Ditto. All but about a dozen channels worked fine. Those dozen channels had a picture but no sound. I contacted comcast but was told to just unplug and re-plug in the tv (no change). I hit the LANG button and instant sound on every channel. Why wouldn't comcast know this by now!!!???
Photo of battrybill

battrybill

  • 1 Post
  • 0 Reply Likes
Even if you don't have DTA hooked up, pressing the "lang" button on the Comcast remote is the fix. Thank you! and Thank you Google.
Photo of Pat

Pat

  • 2 Posts
  • 0 Reply Likes
Lang worked for me, too! You foolishly ask "Why wouldn't Comcast know this by now?" What kind of question is that? It's THEIR equipment. It's THEIR system. The CORRECT question is: "Why couldn't Comcast tell me this?". Frankly, I'm disgusted with them - even more so since their recent "don't worry about the digital conversion - Comcast has you covered", and then they do the same thing requiring you to rent equipment for every television in your house. More bandwidth, or simple money grab - you tell me. I hate Comcast. If satellite were any better, I'd have dropped them eons ago.
Photo of Carlton

Carlton

  • 2 Posts
  • 0 Reply Likes
Consider Free-To-Air (FTA) satellite. It doesn't cost anything per month, you get your pick of satellites (each with their own channel lineup) out of around 24 reachable in the sky over the US, and you get the same quality of customer service (which is to say virtually none).

You do still have to buy your own receiver and dish (typically about $100-$300, depending upon how hard you work to bring in signal from the more marginal satellites in your area), and it's up to you to mount and aim the dish - but you're absorbing that cost in receiver rental or inflated channel plan rates, anyway, when you pay a carrier for television signal. At least this way, all you have to pay is the one-time equipment cost. Beats the heck out of getting a dish through a carrier and then getting penalized for not being able to afford their channel plan, and having to cancel - then being forced to pay for the equipment and still not getting any signal...!
Photo of MOMMY

MOMMY

  • 1 Post
  • 0 Reply Likes
My TV audio was just fine.. except on ~ 2 ~ channels. When you switched to those 2 channels, the audio would be there for like 2-3 seconds, and then would cut out/stop completely. I hav no box, just regular TV hooked up to basic cable. I goggled (and didn't find much) but this thread came up.. got my remote and changed the Audio setting from "Auto SAP" to "Stero".. it immediately fixed the problem!

Unlike the above posters however, I hav only had this problem for about an hour.. all fixed now..!

Timothy thanks for the tip (yours worked..) and to give credit, FARMY FIELDS was the first to suggest the source as being the remote (at the top of this thread) .. but thank you both, truly.

~FLAmazonBlonde
Photo of meganloiselle

meganloiselle

  • 1 Post
  • 0 Reply Likes
amazing!!!!! thank you soooo much!!!! (thankful for the internet too, so I can google all things!) Muah!
Photo of Linda Willis

Linda Willis

  • 1 Post
  • 0 Reply Likes
Brilllian!!! I just got my Comcast Internet & phone I do not have a box or the Comcast remote because I only have Limited Basic..but I noticed that a couple of channels had to sound...so this is what I did...On my own remote (RCA) I clicked the sound button...when I saw the SAP it had a check in it . When I unchecked it....Bingo...Sound. I did the same thing for the other channels now they all have sound....Thanks So Much!!!! I am so glad I didn't have to call Comcast. I hate calling anywhere for technical support. It doesn't matter if it's ATT, Dell, Comcast, etc. etc. because it is a total pain in the you know what. I usually end up getting pissed and hanging up.
Photo of Chris (SU2)

Chris (SU2)

  • 2 Posts
  • 0 Reply Likes
There was no 'lang' button on my remote and I did not have a DTA. I have the cable box. The only solution for me was to unplug the box, wait and replug. After awhile and being dormant for a few minutes while downloading I suppose, it restarted and with sound.