Why Can't i access my email?

  • Question
  • Updated 3 years ago
Okay ive been trying to access my email through my pc. When i access the email through my laptop the email works. however when i try to access the email through the pc it doesnt. I have tried to delete the cache and cookies but still no luck. Ive tried the firewall settings and still no luck. I have been through 7 comcast techs and still no luck. What could the problem possibly be??
Photo of

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 3
Photo of CustomerConnectSherri

CustomerConnectSherri, Employee

  • 84 Posts
  • 4 Reply Likes
Hi Matt,

If it works on your laptop, my logical response would be, there is a setting on your pc, that is preventing you from accessing mail. I apologize that the 7 comcast techs have been unable to detect that setting. We can try to troubleshoot this for you.

Please email us at We_Can_Help@cable.comcast.com with your contact information.

Thanks,
Sherri C.
Comcast Customer Connect
Photo of

  • 1 Post
  • 0 Reply Likes
I have been having the same issue. I connect my laptop to the same internet plug and I get my e-mail instantly. On my computer nothing.

What ended up happening? I went through many tecs and gave up.
Photo of James Oduor Otieno

James Oduor Otieno

  • 2 Posts
  • 0 Reply Likes
joduorotieno@yahoo.com please assist read my mails
Photo of James Oduor Otieno

James Oduor Otieno

  • 2 Posts
  • 0 Reply Likes
access mails
Photo of ChazC

Chaz

  • 2 Posts
  • 0 Reply Likes
We use Comcast as our ISP. I use ultra website as my E-Mail provider/server. Up till now there have been no porblems logging on and retrieving our E-Mails in the office. Friday 13, 2012 we were not able to retrieve any E-Mails.

Any suggestions? Ultra says its not there end and Comcast does not seem to know, however I read the blogs and it seems to be when Comcast changes something the whole system gets buggerd up.
Photo of ChazC

Chaz

  • 2 Posts
  • 0 Reply Likes
This was a suggestion from another blog, however it did not help me because I dont use FIrefox.

I honestly don't understand why Comcast puts their customers thru this every time they update or change their web mail portal interface; why they can't test it in Firefox and see if it works, before releasing the changes and then taking a few months to fix whatever is wrong.

When you're logged into Xfinity Connect open Preferences > General and change it to Xfinity Connect Lite. The "Lite" interface works fine in Firefox for me.