Help get this topic noticed by sharing it on Twitter, Facebook, or email.

BulkAPI Delete status not updated

I ran the following command to queue a bulk delete job:

exec SF_BulkOps 'delete:bulkapi(ns)_', 'OnePlace_MARK', 'GroupMember_delete'

I get the following message indicating that the job was correctly queued.

--- Starting SF_BulkOps for GroupMember_delete V3.3.3
13:41:40: Run the DBAmp.exe program.
13:41:40: DBAmp Bulk Operations. V3.3.3 (c) Copyright 2006-2016 forceAmp.com LLC
13:41:40: Deleting Id's using GroupMember_delete (DC1SVPSFSQL01 / OnePlace_Data_SandBox) .
13:41:41: DBAmp is using the SQL Native Client.
13:41:42: Sort column will be used to order input rows.
13:41:42: SF_Bulkops will NOT poll for results. Later, call SF_Bulkops with Status for results.
13:41:43: Job 750n0000002CMIjAAO created.
13:41:43: Batch 751n0000002HMQXAA4 created with 100 rows.
13:41:43: Job submitted.
13:41:43: 100 rows read from SQL Table.
13:41:43: Check the Salesforce Application Setup / Monitoring / Bulk Data Load Jobs for final job disposition.
--- Ending SF_BulkOps. Operation successful.

When I inspect the table after the job indicates it was successfully queued, I see there is no status. I wait about 5 minutes, and I issue the following command:

exec SF_BulkOps 'Status', 'OnePlace_MARK', 'GroupMember_delete'

This command does not update the status and provides the following feedback:

--- Starting SF_BulkOps for GroupMember_delete V3.3.3
13:44:36: Run the DBAmp.exe program.
13:44:36: DBAmp Bulk Operations. V3.3.3 (c) Copyright 2006-2016 forceAmp.com LLC
13:44:36: Chcecking job status using GroupMember_delete (DC1SVPSFSQL01 / OnePlace_Data_SandBox) .
13:44:36: DBAmp is using the SQL Native Client.
13:44:36: Retrieving Job Status.
13:44:37: 100 rows read from SQL Table.
13:44:37: 0 rows successfully processed.
13:44:37: 0 rows failed.
13:44:37: 100 rows have no job/batch information (never sent to salesforce).
13:44:37: 0 rows marked with current status.
13:44:37: Errors occurred. See Error column of row and above messages for more information.
13:44:37: Error: DBAmp.exe was unsuccessful.
13:44:37: Error: Command string is C:\"Program Files"\DBAmp\DBAmp.exe status GroupMember_delete "DC1SVPSFSQL01" "OnePlace_Data_SandBox" "OnePlace_MARK" " "
--- Ending SF_BulkOps. Operation FAILED.
Msg 50000, Level 16, State 1, Procedure SF_BulkOps, Line 141 [Batch Start Line 28]
SF_BulkOps Error: 13:44:36: DBAmp Bulk Operations. V3.3.3 (c) Copyright 2006-2016 forceAmp.com LLC13:44:36: Chcecking job status using GroupMember_delete (DC1SVPSFSQL01 / OnePlace_Data_SandBox) .13:44:36: DBAmp is using the SQL Native Client.13:44:36: Retrieving Job Status.13:44:37: 100 rows read from SQL Table.13:44:37: 0 rows successfully processed.13:44:37: 0 rows failed.13:44:37: 100 rows have no job/batch information (never sent to salesforce).13:44:37: 0 rows marked with current status.13:44:37: Errors occurred. See Error column of row and above messages for more information.

It seems that the initial command did not retrieve the status markers and thus the status update fails.

Ironically, I wait a while and I do a refresh on the table, and I find that the records were deleted:

--- Starting SF_Refresh for GroupMember V3.3.3
13:45:19: Using last run time of 2017-07-20 12:22:00
13:45:20: Identified 0 updated/inserted rows.
13:45:20: Identified 100 deleted rows.
13:45:20: Removing deleted rows from GroupMember
--- Ending SF_Refresh. Operation successful.

So it seems that the job queued successfully, but the status command fails for some unknown reason. I am running DBAmp 3.3.3. It would be great if I could get a status update. Any insights into this issue would be greatly appreciated.
1 person has
this problem
+1
Reply