Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Custom SF column size change not reflected in local table refresh

I realize this issue may be due to something I don't understand about Salesforce but I'm hoping you can provide some insight.

I added a custom field to the Product table. I set it to a number data type and initially Salesforce set it to a precision of 18 and scale of 0. I accepted that and saved the field.

I ran SF_Refresh to update my local copy and the new field appeared. After thinking a little I decided that a precision of 18 was unnecessary and changed it to 2 and saved it. It now appears as Number(2,0) in the list of custom fields in Salesforce.

I ran SF_Refresh again expecting the column in the local table to now be Decimal(2,0). However, the custom field was still Decimal(18,0). I then ran SF_Replicate and it was still Decimal(18,0).

I then renamed the local table to something like Product2_Old and reran SF_Refresh. Still the local table column is Decimal(18,0).

I ran EXEC dbo.sp_columns_ex SF_SANDBOX, Product2 and TYPE_NAME= decimal, COLUMN_SIZE = 18, DECIMAL_DIGITS = 0. This in spite of what I'm seeing in Salesforce (Number(2,0)).

Do you have any explanation for this behavior?

Thanks in advance.
1 person has
this question
+1
Reply