Help get this topic noticed by sharing it on Twitter, Facebook, or email.

DBamp is erroring on Replication & Refresh

Hello, we are running into a big snafu with replicating data and wondering if you could help out. We are replicating data from SalesForce and our jobs are now either taking forever or breaking.

One object has over 500 fields and the SQL job is reporting this error:
14:14:35: Create Account_Previous with new structure. [SQLSTATE 01000] (Message 0)
14:14:37: Run the DBAmp.exe program. [SQLSTATE 01000] (Message 0). The step failed.

Then when we tried to run it again we got this:

Refresh Service Requests ran for 6:18 hours before failing with this Message:
Executed as user: TWCCORP\svc-ntx-sqlcluster.
Cannot get the data of the row from the OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE".
[SQLSTATE 42000] (Error 7346) --- Starting SF_Refresh for Service_Request__c [SQLSTATE 01000] (Error 0)
18:03:45: Using Schema Error Action of yes [SQLSTATE 01000] (Error 0)
18:03:53: Using last run time of 2013-02-21 18:53:00 [SQLSTATE 01000] (Error 0)
OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE"
returned message "Error 1 : An error has occurred while fetching rows from salesforce.com:
FAHttp::Send::WinHttpSendRequest Win32Error:: The server name or address could not be resolved ".
[SQLSTATE 01000] (Error 7412). The step failed.

Any ideas?
1 person has
this question
+1
Reply
  • Oh and this is another error we are seeing direclty after the error I've listed above

    Cannot get the data of the row from the OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE".
    [SQLSTATE 42000] (Error 7346) --- Starting SF_Refresh for Service_Request__c [SQLSTATE 01000]
    (Error 0) 18:02:12: Using Schema Error Action of yes [SQLSTATE 01000] (Error 0)
    18:02:16: Using last run time of 2013-02-21
    18:53:00 [SQLSTATE 01000] (Error 0) OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE" returned message
    "Error 1 : An error has occurred while fetching rows from salesforce.com: FAHttp::Send::WinHttpReceiveResponse Server Error".
    [SQLSTATE 01000] (Error 7412). The step failed.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly

  • The server name or address could not be resolved ".

    You are losing internet connectivity (perhaps intermittently) . DBAmp cannot connect to the salesforce server.

    If you have a proxy / firewall then I would make sure your configuration has not changed.

    Try remote desktop onto the server and see if you can open a browser there and login to salesforce.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly