Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Error : Cannot obtain the schema rowset

Hi Bill,

Since today I am getting the following error message when using a linked server with the DBAmp provider on all our Salsforce sandboxes, not on our production environment :
Cannot obtain the schema rowset "DBSCHEMA_TABLES" for OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE_PROJECT2".
The provider supports the interface, but returns a failure code when it is used. (Microsoft SQL Server, Error: 7311)

Some technical information :
1. DBAmp version : 2.20.6
2. SQL Server version : SQL Server 2008 SP1
3. The linked server is created in our SQL Server instance and I can connect to it either by the 'Test Connection' option or the 'Security' setting screen.
4. The userid/password I use is correct because I can use it to login into SalesForce application. We tried to connect with and without a security token but that has no influence on the result.
5. When I try to expand the table list (Server Objects > Linked Server > SALESFORCE_PROJECT2 > Catalogs > default > Tables) or try to execute a query on a SalesForce table from SQL Server Management Studio I get the above mentioned error messages.
6. Last night some interfaces, build with SSIS, ran using the same linked server successfully, but when I tried to do one of the actions mentioned in point 5 this morning I got the above mentioned error messages.
7. We have to pass a proxy to get on the internet but if that would cause the problem we shouldn't even be able to do 'Test Connection'.
8. All settings that need to be set on the provider and on the linked server itself are set as mentioned in the DBAmp documentation.

Please let me know how I can solve this asap, because it is messing up our already tight timeline for testing the mentioned interfaces.

Kind regards,
Dirk Diels
Imperial Tobacco
1 person has
this problem
+1
Reply
  • Salesforce is now using SHA-256 certificates for all sandboxes. My guess is that the SQL server machine does not have updated certificates.

    To test this, remote desktop onto the SQL server machine and open a browser. Try to login to the sandbox using the browser. If you are unable to, then the certs on that machine are not up-to-date.

    See the following salesforce article for details: https://help.salesforce.com/apex/HTVi...

    Ask your network team to update the certificates so that you are able to complete a login to the sandbox using the browser. Then retest DBAmp.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated