Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Replicate of LoginHistory not working with Spring 19 release

Hi,

Replicate of LoginHistory table has been working fine but stopped working with the Spring 19 release. I can query the table directly using DBAmp but the following output resultswhen replicating:

--- Starting SF_Replicate for LoginHistory V3.6.6
07:55:35: Parameters: SALESFORCE LoginHistory Version: V3.6.6
07:55:35: Drop LoginHistory_Previous if it exists.
07:55:35: Create LoginHistory_Previous with new structure.
07:55:36: DBAmpNet2 3.6.6.0 (c) Copyright 2015-2017 forceAmp.com LLC
07:55:36: Parameters: replicate LoginHistory_Previous ZEUS4 Salesforce SALESFORCE
07:55:39: Error: System.NullReferenceException: Object reference not set to an instance of an object.
at DBAmpNet2.SFDataLayer3.IsDBNull(Int32 i)
at System.Data.SqlClient.SqlBulkCopy.GetValueFromSourceRow(Int32 destRowIndex, Boolean& isSqlType, Boolean& isDataFeed, Boolean& isNull)
at System.Data.SqlClient.SqlBulkCopy.ReadWriteColumnValueAsync(Int32 col)
at System.Data.SqlClient.SqlBulkCopy.CopyColumnsAsync(Int32 col, TaskCompletionSource`1 source)
at System.Data.SqlClient.SqlBulkCopy.CopyRowsAsync(Int32 rowsSoFar, Int32 totalRows, CancellationToken cts, TaskCompletionSource`1 source)
at System.Data.SqlClient.SqlBulkCopy.CopyBatchesAsyncContinued(BulkCopySimpleResultSet internalResults, String updateBulkCommandText, CancellationToken cts, TaskCompletionSource`1 source)
at System.Data.SqlClient.SqlBulkCopy.CopyBatchesAsync(BulkCopySimpleResultSet internalResults, String updateBulkCommandText, CancellationToken cts, TaskCompletionSource`1 source)
at System.Data.SqlClient.SqlBulkCopy.WriteToServerInternalRestContinuedAsync(BulkCopySimpleResultSet internalResults, CancellationToken cts, TaskCompletionSource`1 source)
at System.Data.SqlClient.SqlBulkCopy.WriteToServerInternalRestAsync(CancellationToken cts, TaskCompletionSource`1 source)
at System.Data.SqlClient.SqlBulkCopy.WriteToServerInternalAsync(CancellationToken ctoken)
at System.Data.SqlClient.SqlBulkCopy.WriteRowSourceToServerAsync(Int32 columnCount, CancellationToken ctoken)
at System.Data.SqlClient.SqlBulkCopy.WriteToServer(IDataReader reader)
at DBAmpNet2.Processor.Run()
07:55:39: 0 rows copied.
07:55:39: DBAmpNet2 Operation FAILED.
07:55:41: Error: Replicate program was unsuccessful.
07:55:41: Error: Command string is C:\"Program Files"\DBAmp\DBAmpNet2.exe Exportsoap "Replicate" "LoginHistory_Previous" "ZEUS4" "Salesforce" "SALESFORCE"
--- Ending SF_Replicate. Operation FAILED.
Msg 50000, Level 16, State 1, Procedure SF_Replicate, Line 370 [Batch Start Line 38]
--- Ending SF_Replicate. Operation FAILED.

I have tried deleting the local LoginHistory and LoginHistory_Previous tables and no change. The replication works on our test system to the Sandbox. This uses version 3.6.5 (vs 3.6.6 on the production system).

Haven't tried upgrading to the latest DBAmp yet. Will this fix it or is there another cause for this problem?

Thanks

Dave
1 person has
this problem
+1
Reply