Required Transaction Interface

I have a scheduled job that is failing and giving this error: The requested operation could not be performed because OLE DB provider "DBAmp.DBAmp" for linked server "salesforce" does not support the required transaction interface. [SQLSTATE 42000] (Error 7390).

We recently cut over to a new server, where this job was previously running successfully. The job is fairly simple, and makes use of dbAmps bulk ops procedure. Any info to help troubleshoot would be much appreciated. Thanks.
1 person has
this question
+1
Reply
  • Sounds like you missed an installation step.

    Check the DBAmp.DBAmp provider options (Servers/Link Servers/Providers/right click on DBAmp.DBAmp. The following options should be checked:

    Dynamic Parameters
    Allow In Process
    Non transacted Updates

    Also, make sure the Collation Compatible is checked for the link server itself.

    After making the changes, retry the operation. If the error still occurs, then you have to restart the SQL instance for the changes to take effect.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned