Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m sad

SF_Refresh gives Win32Error:: The operation timed out. Cannot get the data of the row from the OLE DB provider "DBAmp.DBAmp"

We're having all sorts of troubles on a server that used to work. Now there's increasing intermittent failure, especially with the Lead table- we haven't been able to successfully refresh it in days. We recently asked SFDC to increase our timeout so that we could get the LeadHistory table, but other than that I don't think anything has changed. Any ideas welcome.

Here's the most current error after 6 minutes:
--- Starting SF_Refresh for Lead
11:30:38: Using last run time of 2012-05-02 00:36:00
OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE" returned message
"Error 1 : An error has occurred while fetching rows from salesforce.com: SFWinInet::Send::HttpEndRequest
Win32Error::
The operation timed out
".
Msg 7346, Level 16, State 2, Line 1
Cannot get the data of the row from the OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE".

And another from last night/this morning before reboot- this was after 10.5 hours:
--- Starting SF_Replicate for Lead
15:03:28: Drop Lead_Previous if it exists.
15:03:30: Create Lead_Previous with new structure.
15:03:52: Run the DBAmpReplicate program.
15:03:54: DBAmp Bulk Operations. V2.11.4 (c) Copyright 2006-2009 forceAmp.com LLC
15:03:54: Replicating into Lead_Previous , MY_SERVER / salesforce backups .
15:04:00: Opening SQL Server rowset
01:05:49: Error: An error has occurred while fetching rows from salesforce.com.
01:05:49: SFWinInet::Send::HttpEndRequest
Win32Error::
The server returned an invalid or unrecognized response

01:05:49: Error: Replication failed.
Source: SForceOfficeToolkit4.SQueryResults4.1
Description: SFWinInet::Send::HttpEndRequest
Win32Error::
The server returned an invalid or unrecognized response

01:32:50: Error: DBAmpReplicate was unsuccessful.
01:32:50: Error: Command string is C:\"Program Files"\DBAmp\DBAmpReplicate.exe Export Lead_Previous "MY_SERVER" "salesforce backups" "SALESFORCE"
--- Ending SF_Replicate. Operation FAILED.
Msg 50000, Level 16, State 1, Procedure SF_Replicate, Line 168
--- Ending SF_Replicate. Operation FAILED.
1 person has
this problem
+1
Reply