Help get this topic noticed by sharing it on Twitter, Facebook, or email.

SF_Replicate not updating table

Hello,
We have DBAmp on a SQL server 2008 and I am running SQL and connecting to the SQL Server from my PC not the server. When I run SF_Replicate_All it updates from my PC with out issue. If I run the SF_Replicate it advises no errors but doesn't update the table locally to the same database that SF_ReplicateAll updates. I know the issue is probably to do with the location of DBAmp looking at 'C:\"Program Files"\DBAmp\' in the procedure but I have tried using a shared location, and a mapped location to it from my PC but SF_Replicate doesnt work even though it says it does.

Here is the table I am trying to recreate in sql window-
exec SF_Replicate 'SALESFORCE_TEST' , 'Invoices__c'

Results state :
--- Starting SF_Replicate for Invoices__c
14:31:31: Drop Invoices__c_Previous if it exists.
14:31:31: Create Invoices__c_Previous with new structure.
14:31:34: Run the DBAmp.exe program.
14:31:34: DBAmp Bulk Operations. V2.16.8 (c) Copyright 2006-2013 forceAmp.com LLC
14:31:34: Populating local table Invoices__c_Previous , SRVDBS02 / SF_Vita .
14:31:35: DBAmp is using the SQL Native Client.
14:31:35: Opening SQL Server rowset
14:31:36: 233 rows copied.
14:31:36: Drop Invoices__c if it exists.
14:31:36: Rename previous table from Invoices__c_Previous to Invoices__c
Caution: Changing any part of an object name could break scripts and stored procedures.
14:31:36: Create primary key on Invoices__c
--- Ending SF_Replicate. Operation successful.

When I check the table the record count to SF and the local db is different. They should be the same. I have run it on the server and of course it works fine. I need to run this through SSIS and not run the pacakge on that particular server

Any ideas how I can make a (possibly) additonal procedure to point to the local pc I am on to run the same process as if I was in the server. Server address is \\srv\dbamp (shared location). I tried '\\srv\dbamp\' in the procedure but it didn't work and 'X:\' (mapped location on my pc) and also didn;t work. Is it possible to run what we are wanting to do.

Any help would be apprciated.

Thanks

Mike
1 person has
this problem
+1
Reply