Loading time

  • Problem
  • Updated 6 years ago
  • In Progress
I'm using Google Chrome from Norway on a 3000 kbit/s connection. The site loads slow from time to time, but it might be because of my location.
Photo of ctrlclick

ctrlclick

  • 1 Post
  • 0 Reply Likes
  • happy

Posted 6 years ago

  • 5
Photo of Damian Madray

Damian Madray, Creative Director

  • 230 Posts
  • 20 Reply Likes
We'll look into loading time after we resolve some other pressing issues.
Photo of Damian Madray

Damian Madray, Creative Director

  • 230 Posts
  • 20 Reply Likes
We've shaved 15secs off load time for the site. Feel free to double check it and see if it has improved on your end.

We're still going to be working on it and leave this open to see if anyone has issue with loading.

Thanks.
Photo of madnessism

madnessism

  • 12 Posts
  • 0 Reply Likes
I'm using Firefox and having the same issue as of today, just FYI. :)
Photo of Damian Madray

Damian Madray, Creative Director

  • 230 Posts
  • 20 Reply Likes
Strange, for the most parts this site should be fast for we've been working on that for weeks. It loads fast and even community page was increased.

Can you elaborate? Which page? How long? What's your connection?
Photo of madnessism

madnessism

  • 12 Posts
  • 0 Reply Likes
It doesn't seem to be on a specific page, just randomly pages will take ages to load. I'll browse around more and see if I notice it on any pages in particular. My connection isn't the issue, just trust me on that one. ;)
Photo of Damian Madray

Damian Madray, Creative Director

  • 230 Posts
  • 20 Reply Likes
How does the site perform now guys? Better? Or still painfully slow loading?
Photo of Maxime Chillemi (barbroute)

Maxime Chillemi (barbroute)

  • 8 Posts
  • 0 Reply Likes
It is still slow for me.
Photo of Mark

Mark

  • 42 Posts
  • 1 Reply Like
Still slow here.
Photo of Damian Madray

Damian Madray, Creative Director

  • 230 Posts
  • 20 Reply Likes
Ok, can we have another look at speed. I strongly believe based on other comments that it has increased. It turns out that our previous host wasn't as fast as we thought it was. Our current host is an improvement.

Let us know.
Photo of Maxime Chillemi (barbroute)

Maxime Chillemi (barbroute)

  • 8 Posts
  • 0 Reply Likes
It's better on my computer :)
Photo of Mark

Mark

  • 42 Posts
  • 1 Reply Like
Much much better!
Photo of Damian Madray

Damian Madray, Creative Director

  • 230 Posts
  • 20 Reply Likes
Guys,

We implemented the 'get satisfaction' feedback pop-up. Let me know if you noticed a changed recently in speed? If you do I'll remove it again - it's not worth that trouble.