I’m annoyed

Cannot Login to Account to add ID details

I spent three hours on hold to easyjet waiting for help regarding this.

After numerous emails and alot of wasted time Easyjet have not resolved my problem.
I am unable to login to add my details for the flight, although I have paid I cannot login to the section of the site https://www.easyjet.com/en/myeasyjet/...

It says "Please review the details you have provided"
I have used the forgotten password section and it confirmed for me that I am entering the correct details.

Instead of simply loging into the backend system and editing the account to allow me access the support team have told me to call in for support.
Now I dont mind that, but 3 hours on hold? That cost me more than 18 pounds and I still didnt get through.

I have tried using the faq section on the website for help, tried logging in without a password as was suggested, this did not resolve the problem.
As you can see i can easily login to the support section, its the section for adding passenger details, password info etc that i canot access.

This issue needs to be sorted quickly!

I hope there is someone working for Easyjet that can actually help, this is my first experience with Easyjet.
I know what needs to be done, somone just needs to access the account details on the backend system, reset the password and check they can login ok, then provide me with the new password, a process that should take about 5 minutes.

I am now on day 3 trying to get this resolved!

Lets hope that the quality of service from this point onwards will improve, I dont think it can get much worse.

edit -

The password has a & in it.
When i tried logging in using %26 instead of & i get the error:
"Sorry, but something has gone wrong. [ej2 exception] "

And the livechat function says it will not work on this account.

Is there anyone that can help please?
4 people have
this question
+1
Reply