Console me!

  • Problem
  • Updated 5 years ago
  • Solved
I have just installed the current version of Easy Peasy on my EEE PC 900. Problem: cntl+left alt+ Fn does not bring up a virtual terminal with a login prompt, only a black screen. I have also tried the openvt and chvt commands, and gotten the message: "Couldn't get a file descriptor referring to the console". Suggestions?
Photo of Terry BrennanTB

Terry Brennan

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of kakaw

kakaw

  • 207 Posts
  • 23 Reply Likes
Are you able to get into a terminal through the GUI?
Photo of Terry BrennanTB

Terry Brennan

  • 4 Posts
  • 0 Reply Likes
I am able to bring up an xterm window in the GUI.

BTW, if I press cntl+left alt+Fn and get a blank screen, I am able to return to the GUI with cntl+left alt+F7. So the system reads the Fn keys, it just does not open a TTY with F1 - F6.

Terry Brennan
Photo of kakaw

kakaw

  • 207 Posts
  • 23 Reply Likes
There's a thread here about editing your keyboard shortcuts:
http://ubuntuforums.org/showthread.ph...
Does that help?
Photo of Terry BrennanTB

Terry Brennan

  • 4 Posts
  • 0 Reply Likes
No, sorry. I think I found the screen you mean: in EesyPeasy it is Keyboard Preferences. It makes no reference to cntl+left alt+Fn. In any case, when I try to get to a virtual terminal with a terminal command (chvt or openvt) I get the message "Couldn't get a file descriptor referring to the console". This indicates that the problem is not a keyboard problem.

Terry B.
Photo of kakaw

kakaw

  • 207 Posts
  • 23 Reply Likes
This may be a security "feature". It looks to me like this Q&A addresses the issue:
http://superuser.com/questions/69807/...
Please correct me if I have misunderstood your question.
Photo of Terry BrennanTB

Terry Brennan

  • 4 Posts
  • 0 Reply Likes
Problem solved. I should have remembered, in Linux, find the config file and the problem will probably go away. In this case, the config file(s) are /etc/init/gettyN where N= 1-6. In each of these files there is a line specifying under which runlevels the program getty should be executed for that virtual terminal. For term 1, the default is runlevels 2-5. For terms 2-6 the default is runlevels 2 and 3. Since EasyPeasy comes up in run level 5 by default, term 1 comes up, but not 2 - 6. Adding runlevel 5 in files 2-6 solves the problem.

Thanks to kakaw for his time on this problem.

Terry B