Mailstore Home IMAP results in disconnected on every attempt

  • Question
  • Updated 10 months ago
  • Answered
I have been using Mailstore Home for quite some time and have built up a large offline archive from my online IMAP provider GoDaddy. My local archive is approximately 1.4 GB with around 45,000 messages. Lately, on every use of MailStore Home, the archiving process will begin and work for awhile (today it processed about 2700 messages) and then it will stop with an error that says:

"The process has been aborted because the network connection has been disconnected.
256 new messages have been archived.
4,889 messages already existed in the archive.
56 messages were duplicates of messages processed before and have therefore been skipped.
1 errors occurred (see below).
Unable to read message headers for a message in folder Archive with date 5/28/2008 5:36 AM from the IMAP server.

Archive

Your Amazon.com Order (D01-2551745-3263927) (failed)
Invalid IMAP response."

Here is the end of my log file where it appears to start to have problems:

"10:12:20.857 [8] INFO Notify:BeginItem 'Your Amazon.com Order (D01-2551745-3263927)'
10:12:20.857 [8] INFO Now processing e-mail message with MessageID: urn.correios.msg.20111215083226dc6e8b..., HeaderHash: 5da99c4404c70b632ff56bf67700653447e4de21; Date: 12/15/2011 8:33:02 AM; DisplayName: 'Your Amazon.com Order (D01-2551745-3263927)'
10:12:20.860 [8] INFO Retrieving message...
10:12:20.860 [8] INFO Retrieving message with UID EaToeQAABij
10:12:21.142 [8] EXCEPTION Rebex.Net.ImapException: Invalid IMAP response.
at Rebex.Net.Imap.ReadResponse(String command, ImapResponseKind kind, String tag, Boolean idle)
at Rebex.Net.Imap.Fetch(ImapMessageSet messageSet, Int32 fields, UInt32 validity, Boolean ignoreMissingMessages, String partial)
at Rebex.Net.Imap.FetchMessageList(ImapMessageCollection list, ImapMessageSet messageSet, Int32 fields, UInt32 validity, Boolean ignoreMissingMessages, String partial, Int64 partialOffset)
at Rebex.Net.Imap.GetMessageListInternal(ImapMessageSet messageSet, Int32 fields, Boolean ignoreMissingMessages, Int64 partialOffset, Int32 partialCount)
at Rebex.Net.Imap.GetMessageInternal(String uniqueId, Int32 fields, Int64 partialOffset, Int32 partialCount)
at Rebex.Net.Imap.GetMessage(String uniqueId, Stream output)
at x1e0a3ab552a37532.xc6868ccfe102eb19.x538d63a1354c16f2(Object xba08ce632055a1d9, Stream xcf18e5243f8d5fd3)
at x8894990f73349d39.xc31d7520e8eb9685.x119a5f320fada9ff(xa7a8289ea6887c97 x8a41fbc87a3fb305, String x8b5b49efcd08ae0a, Nullable`1 xebf45bdcaa1fd1e1)

10:12:21.142 [8] INFO Notify:SetItemStatus 'xdc1af3a17717bf0a'
10:12:21.143 [8] INFO Notify:UpdateItem 'Your Amazon.com Order (D01-2551745-3263927) (failed)'
10:12:21.144 [8] INFO Uninitializing...
10:12:21.266 [8] WARN Worker has been cancelled (connection disconnected)."

jkcarp

  • 1 Post
  • 0 Likes
  • frustrated

Posted 2 years ago

  • 1

Tim, Official Rep

  • 978 Posts
  • 16 Likes
The error indicates a problem with the IMAP server which occurs if MailStore tries to retrieve an email.

To find out what exactly happens within the connection we need a connection debug log. Therefore please start MailStore Home, click on About MailStore Home -> Enter Support Command and enter the following command: debug-conn

The output of the command shows you where you will find the log file later. Please run the archiving profile again and send us the log file when the process has finished. [-> support@mailstore.com]

Please note that the connection log could imply your IMAP password.

Marcel

  • 2 Posts
  • 0 Likes
So I have the same problem. I have now tried to backup my Gmail IMAP mailbox 6 times. Stalls each time at the same point. I even have deleted the message where it stops, but it still stops at the same point. I can read these last message fine inside Gmail. I do not believe this is a network connection problem but some other issue. Time-out settings increased from 300 sec to 600 sec made no difference. First time, 5,000ish messages backed up, 2nd time 1 message, 3rd time 0, 4th time 0, 5th time 2 messages, 6th time 0. Backing up another (much smaller) Gmail mailbox works fine. I use MailStore Home 5.

Log page gives following detail:

The process has been aborted because the network connection has been disconnected.
1 new messages have been archived.
5,225 messages already existed in the archive.
2 errors occurred (see below).

[Google Mail]/Sent Mail

RE: Pls validate BPO presentation + add missing details for BI and DM - Thanks (failed)
The IMAP server has returned an error. System Error (Failure) (NO).

RE: xxx has sent a question about item #320363xxx915, that ended on 22-May-09 11:01:31 BST - CLP-310/315 Samsung Printer xxx -2nd Version (failed)
The server has closed the connection.

Log file has the following last entries:

22:43:48.598 [13] INFO Notify:SetItemStatus 'xdc1af3a17717bf0a'
22:43:48.598 [13] INFO Notify:UpdateItem 'RE: xxx has sent a question about item #320363xxx915, that ended on 22-May-09 11:01:31

BST - CLP-310/315 Samsung Printer xxx -2nd Version (failed)'
22:43:48.601 [13] INFO Uninitializing...
22:43:48.626 [13] WARN Worker has been cancelled (connection disconnected).

Did the debug log from jkcarp throw up any clues? Happy to email my one also.

Tim, Official Rep

  • 978 Posts
  • 16 Likes
We didn't receive any feedback from jkcarp.

Therefore you are welcome to send us your connection log.

Marcel

  • 2 Posts
  • 0 Likes
So I sent the connection log to Tim. Who came back quickly with the suggestion to move the message where the backup stalled to a Gmail folder that will not be archived.

Following some experimentation and careful inspection of the log files, I deleted a total of 4 messages within Gmail, doing a permanent delete in the Gmail Bin followed by a retry of the backup. I decided this was more certain than to leave them in another folder. After message #4 it was able to continue past the failure point. It is now happily churning through my mail box.

Assume this has resolved the problem (unless I come back here).

Thanks Tim.

Tim, Official Rep

  • 978 Posts
  • 16 Likes
Thanks for your feedback.

Nan Josephson

  • 5 Posts
  • 0 Likes
I am having the same problem. BUT I have removed the problem files and it keeps doing it over and over, even after I have removed the problem files. It progresses past the problem files and finds OTHER problems files on which to stall. The latest is:

The process has been aborted because the network connection has been disconnected.

6,339 messages already existed in the archive.

2 errors occurred (see below).

China

10/22/2004 11:04 PM HELLO FROM NAN
The IMAP server has returned an error. System Error (Failure) (NO).

10/22/2004 10:15 PM PP CHINA ATTACHMENT
The server has closed the connection.

Nan Josephson

  • 5 Posts
  • 0 Likes
Here is the Debug Log:

Product Name: MailStore Home
Product Version: 7.0.7.7671
App Build Date: 2012-07-05
App Copyright: Copyright (c) 2005-2012 MailStore Software GmbH
App Description:
App Dir: C:\Program Files\deepinvent\MailStore Home
App File Name: C:\Program Files\deepinvent\MailStore Home\MailStoreHome.exe
App Title: MailStore
Operating System: Microsoft Windows NT 6.0.6002 Service Pack 2
OS Bitness: x86
Process Bitness: x86
Is Mono: False
Is Windows: True
.NET Framework 2.0: Version 2.0.50727.4016 installed
.NET Framework 3.5: Version 3.5.30729.01 installed
Proc Culture: en-US
Proc UI Culture: en-US
Machine Name: OWNER-PC
User Domain Name: Owner-PC
User Name: Owner

11:02:37.422 [9] INFO Worker started.
11:02:37.423 [9] INFO Notify:SetTitle 'mcjosephson@gmail.com'
11:02:37.424 [9] INFO Initializing...
11:02:37.424 [9] INFO Connecting to imap.googlemail.com:993, protocol: IMAP-SSL
11:02:37.572 [9] INFO Authenticating user mcjosephson@gmail.com
11:02:37.783 [9] INFO Retrieving folders (Google Mail special implementation)
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [Inbox]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.886 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO Folder is not selectable. Skipping.
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [AllMail]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [Drafts]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [Sent]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [Spam]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [Starred]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [Trash]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO * Rebex.Net.ImapFolder [(null)]
11:02:37.887 [9] INFO Archiving configuration:
11:02:37.887 [9] INFO Source Mailbox: xd1c9ab197ebcfeab.xc6868ccfe102eb19
11:02:37.887 [9] INFO Source Mailbox Name: (null)
11:02:37.887 [9] INFO Source E-mail Address: mcjosephson@gmail.com
11:02:37.887 [9] INFO Source Folders Include:
11:02:37.887 [9] INFO Source Folders Exclude:
11:02:37.887 [9] INFO Source Folders Auto-exclude: True
11:02:37.887 [9] INFO Source Folders Inbox+sf only: False

Tim, Official Rep

  • 978 Posts
  • 16 Likes
Does it always stall when archiving the same messages mentioned above?

Nan Josephson

  • 5 Posts
  • 0 Likes
Tim,
No. When it stalls, it give me two details. I have been copying those problem emails into a Word document and storing it on my external hard drive. Then I delete them from the email, and remove them from the Trash. (Some of the emails have no attachments and appear to be just routine emails. Some of the emails have attachments as part of the emails.) Then I restart the backup through MailStore Home 7. I have had to do this about ten times +/- at this time. MailStore starts the process again, and stalls on some other emails. I am backing up from 2005 to present. So far, I have not even made it through 2006 emails yet. At this rate, it will take literally days and days to backup the email.

Tim, Official Rep

  • 978 Posts
  • 16 Likes
Do you have an anti-virus software installed that scans the IMAP protocol ?
In that case I would deactivate the protocol scanning temporarily.

To find out what exactly happens within the connection we need a connection debug log as I described above in my first answer to jkcarp:
.

Nan Josephson

  • 5 Posts
  • 0 Likes
I did send you the debug log. It is posted above.

Tim, Official Rep

  • 978 Posts
  • 16 Likes
Yes but we need the connection log not the debug log. Therefore please start MailStore Home, click on About MailStore Home -> Enter Support Command and enter the following command: debug-conn

The output of the command shows you where you will find the log file later. Please run the archiving profile again and send us the log file when the process has finished. [-> support@mailstore.com]

Please note that the connection log could imply your IMAP password.

Nan Josephson

  • 5 Posts
  • 0 Likes
When I tried this, I got the following response:

c:\>ProgramData\MailStore\Debug Log\Connection
'ProgramData\MailStore\Debug' is not recognized as an internal or external command,
operable program or batch file.

c:\>ProgramData\MailStore\DebugLog\Connection
This system cannot find the patch specified.

Tim, Official Rep

  • 978 Posts
  • 16 Likes
Did you run the command inside MailStore Home as shown in the screenshot?

Leonid Sirov

  • 1 Post
  • 0 Likes
I had the same problem. Disabling NOD 32 Antivirus helped.

Florent

  • 1 Post
  • 0 Likes
Hello
I'am testing Mailstore Server, with error "invalid imap response"
I disable the "IMAP protocol" in ESET Endpoint Antivirus: no longer error :)

Tim, Official Rep

  • 978 Posts
  • 16 Likes
Thanks for your feedback.