Unable to open the master database - GBAK exited with code 1

  • 1
  • Problem
  • Updated 3 months ago
  • In Progress

Having reinstalled the operating system on my PC (Win 10 Pro) I reinstalled Mailstore Home and copied files as detailed in here (Backup and Restore)

When running Mailstore Home – Configuration it crashes and reports “Unable to open the master database in C:\Users\John\Documents\MailStore Home. GBAK exited with code 1”.   I have tried using files from different back ups. 

Log information:
*** Preserved Stack Trace ***
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#iRl(String #jRl, String #lOf, WriteLineCallback #KMf)
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#hRl(String #pfc, String #qfc, WriteLineCallback #KMf)
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#kRl(String #vP, WriteLineCallback #KMf)
   at MailStore.Storage.MailStore_.#3tf(String #vP, ProductType #h4e, #kVe #Tcg, Func`1 #Q2l, Byte[] #p1l, String #Tbf, Boolean #Ucg)
07:24:54.165 [1] EXCEPTION: Caller of MessageDlg.Exception
System.Exception: Unable to open the master database in C:\Users\John\Documents\MailStore Home. GBAK exited with code 1.
   at #D0c.#Kqm.#Hqm(Int32 #Iqm, Action #Jqm)
   at MailStore.Home.HomeApplication.#Q0c(String #d4, Boolean #Trm)
   at MailStore.Home.HomeApplication.#L0c(#vGk #H8f)

*** Preserved Stack Trace ***
   at MailStore.Storage.MailStore_.#3tf(String #vP, ProductType #h4e, #kVe #Tcg, Func`1 #Q2l, Byte[] #p1l, String #Tbf, Boolean #Ucg)
   at MailStore.Home.HomeApplication.#1zl.#Urm()
   at #D0c.#Kqm.#OKl.#Nqm()

*** Inner Exception ***
System.Exception: GBAK exited with code 1.
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#iRl(String #jRl, String #lOf, WriteLineCallback #KMf)
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#hRl(String #pfc, String #qfc, WriteLineCallback #KMf)
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#kRl(String #vP, WriteLineCallback #KMf)
   at MailStore.Storage.MailStore_.#3tf(String #vP, ProductType #h4e, #kVe #Tcg, Func`1 #Q2l, Byte[] #p1l, String #Tbf, Boolean #Ucg)

*** Preserved Stack Trace ***
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#iRl(String #jRl, String #lOf, WriteLineCallback #KMf)
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#hRl(String #pfc, String #qfc, WriteLineCallback #KMf)
   at MailStore.Storage.FirebirdEmbedded.FirebirdEmbeddedDatabase.#kRl(String #vP, WriteLineCallback #KMf)
   at MailStore.Storage.MailStore_.#3tf(String #vP, ProductType #h4e, #kVe #Tcg, Func`1 #Q2l, Byte[] #p1l, String #Tbf, Boolean #Ucg)
Photo of John

John

  • 1 Post
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Tim

Tim, Technical Support Engineer

  • 1329 Posts
  • 43 Reply Likes
Please post a screnshot of the file and folder structure of your archive directory.
Photo of charles betts

charles betts

  • 1 Post
  • 0 Reply Likes
I had same problem.  However, I uninstalled and rather than Windows 10 choose file/ location to save emails I designated my own folder.  I steered away from default/ user folder chosen by Windows and just put a folder called Mailstore Data in  C.   ie C:\Mailstore Data. That cured the problem.
I then tried another option as an experiment as I have a separate D Drive to store all my data.  Removed the  C:\ Mailstore folder and relocated the Mailstore folder for archiving on D drive. Simply called it D:\Mailstore.  Make sure its designated in the Mailstore Administrative tools options.
I've had similar problems with other programmes being "corrupted" by Windows 10 setting the folder where it thinks  programme installation should go and making a mess.
Photo of Rebecca

Rebecca, Official Rep

  • 137 Posts
  • 12 Reply Likes
Hello John,

did you try Charles' idea of moving the backup database to a new position?
You may also want to check the properties of that newly created folder. Make sure it is not write protected (that might happen when it comes from a different file system like CD/DVD or network).
Then start the MailStore Configuration again and choose that folder.

Did that help?