Unable to Access MailStore Data

  • Problem
  • Updated 2 years ago
  • In Progress
I originally was using MailStore 4. I had to reinstall windows and thus reinstall Mailstore 5. However when I try to access my old data i am not able to. I get different errors from the system. Please note that I have a domain controller at my home and use folder redirection to the fileserver. MailStore never had a problem with it before but now reports that it cannot connect to the database. If i point it to the mailstore dir i get the following error:

The selected directory does not contain a usable email archive. (v4)

After reinstalling v5 again i get an error that :Mailstore Home only supports local drives

if i move the data to a local drive i get the following error "MailStore Home was unable to open the archive. Details: Unable to open the filer group in ... The database belongs to a different MailStore.

Please help, all of my backups produce the same result!!!

dstalls

  • 7 Posts
  • 0 Likes
  • frustrated

Posted 2 years ago

  • 1

Andreas

  • 34 Posts
  • 1 Like
This sound like you mixed the master database and filegroup database from two different installation. Probably the master database is from a newly installed MailStore Home and the filegroup database is from your old archive.

I suggest to restore your last working backup, store it into a location that is supported by MailStore Home 5 and use the "Select Data Directory Tool" to point MailStore Home 5 to that directory. It should then detect the old version 4 archive and update it to the new format.

Unfortunately MailStore Home never supported storing the archive on a network drive. It is surprising to see that it worked with folder redirects.

dstalls

  • 7 Posts
  • 0 Likes
Is there any way to rebuild or reproduce these files. All of my backups are post the folder redirection so there is nothing else to recover other than the data (which MailStore saved to "MyDocuments").