alt-click doesn't work

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Like the Chrome user in another post I am stuck at the "Press alt and click on these bases (bases 20 and 21)" step of [Liquid Robotics] Level 8 of 11 because the glue tool won't work. I use Linux Mint and I don't have another computer available.
Is there a workaround for this? I would really like to continue...even without the glue tool...

Btw: the alt-button seems to work with linux (unlike with Chrome), the 'cursor' does turn blue, but clicking doesn't 'glue' anything,
how can I continue with the puzzle ? Maybe add an 'ok' button in the 'press alt and...' message so I can bypass the problem ?
Photo of yulan

yulan

  • 17 Posts
  • 0 Reply Likes
  • all hyped up and ready to go

Posted 2 years ago

  • 1
Photo of Omei Turnbull

Omei Turnbull, Player Developer

  • 963 Posts
  • 303 Reply Likes
Hi yulan!  Because you say "the 'cursor' does turn blue", I wonder if alt-click is working fine, but you don't realize how the glue tool works.  Here's a quick test -- see if you can reproduce what I have done:



In this first screenshot, note that I am in "Natural" mode, as evidenced by the Leaf icon being highlighted.  (In Natural mode, the folding will reflect how the folding engine predicts the molecule will fold in nature.)  I have selected nine bases, 5 in one sequence and 4 in the other.

But to actually "glue" things together, you have to identify two (and only two) segments that are exactly the same length.  So to activate the glue, I mark one additional base on the right hand side. When I do that, this is what I see:

The blue simply goes away, making it look like nothing happened.  But that's because I am in Natural mode, and I haven't mutated any bases.  To see the effect of what I have done, I have to switch to Target mode, by pressing the target icon to the right of the leaf.


Here, I see that the two sequences I had highlighted are glued together in the sense that I have expressed my intent to design an RNA sequence where these two sequences bind together in Natural mode.

Hopefully, that will clear up your problem.  But if not, please post again with screenshots showing what does happen on your machine.
Photo of yulan

yulan

  • 17 Posts
  • 0 Reply Likes
Hi Omei,

thanks for your quick reply. I doublechecked to see if I'm doing it right as you showed, It seems I am...
What I meant was: the mouse-pointer turns blue if I alt-click but I can't select any bases, so it seems the button works but the 'event' isn't 'handled' right so nothing happens (unlike ctrl-click: I can select/mark bases fine with that), see uploaded screenshots,
I am using Firefox in Linux Mint, could this be the problem ? I haven't had the chance to try a windows pc yet...
The tutorial won't let me continue but I would like to get past this point and progress towards labs....
grts Yulan

Photo of Omei Turnbull

Omei Turnbull, Player Developer

  • 963 Posts
  • 303 Reply Likes
OK, I understand what you meant now.  Sorry I was a little dense.

Doing a Google search for alt left click on linux mint, I see this is a long-standing issue with Mint users.  As with many of this kind of issue, there are numerous posts that tell how certain people were able to fix their own scenarios, but it is difficult to tell whether their solution will be relevant to you.

Here's one easy suggestion that was confirmed to work by a second user:
Re: Cinnamon 1.6 (mint 14) alt + click binding
Postby lexington523 » Tue Aug 27, 2013 5:37 pm
I searched for a long time for this. I finally found a solution on my own. I have a much easier answer than most of the solutions that I found. This is confirmed to work in Mint 15 and probably is present in earlier editions.
go to: system settings --> windows
locate "modifier to use for modified window click actions"
change it from "Alt" to nothing.
and that's all there is to it. none of this complicated stuff. I don't know why that was so impossible to find in online forums.

If that doesn't work, the best I can suggest is to look through all the other threads and see if you can find anything else that succeeds for you.  And please do let us know here if you do find a solution.
Photo of yulan

yulan

  • 17 Posts
  • 0 Reply Likes
Thanks for the google search Omei, should have thought of that myself...thought it was an Eterna issue... I am going to try the above and other threads and I'll get back to you with what works,

thanks again, your help is much appreciated,
grts Yulan
Photo of yulan

yulan

  • 17 Posts
  • 0 Reply Likes
Yes!! The above solution (go to: system settings --> windows
locate "modifier to use for modified window click actions",
change it from "Alt" to nothing.) works / fixed my Alt-click problem. Recommended for Linux Mint Users! So happy to be able to continue my EteRNA journey !