Chat is gone!

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
Chat is gone!  
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes

Posted 3 years ago

  • 2
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
It seems so. I have a hunch that some bad code was pushed in preparation for the new HTML chat launch. I'm looking into it now.
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
Update: Seems like a Flash update released yesterday is the cause. Looking into what our options are.
Photo of nando

nando, Player Developer

  • 388 Posts
  • 71 Reply Likes
Indeed, nothing was changed on our end of things, it's an Adobe update, which was automatically pushed on most browsers.

At this point, I don't even know if I can do something about it (like a work-around perhaps), or if it's all in Adobe's hands...

I'll post as soon as I have news.
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
It appears that this issue is also impacting the game itself on some browsers. I'm assuming someone on the team will be contacting Adobe to get this resolved.
Photo of nando

nando, Player Developer

  • 388 Posts
  • 71 Reply Likes
Following wasn't happening with previous Adobe Flash builds:



I still don't know where it comes from... At minimum, I'm going to work on a patch that allows everyone to play and participate in labs.
Photo of nando

nando, Player Developer

  • 388 Posts
  • 71 Reply Likes
A good news and a bad one: I finally have found a workaround, but it's a somewhat complicated one, and not completely satisfactory (specially for new players). I need a break though (been on it for 6 hours straight), so I'll post about my findings in a couple hours.
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
Thanks for your hard work Nando!
Photo of nando

nando, Player Developer

  • 388 Posts
  • 71 Reply Likes
Procedure:
  • add the line EnableInsecureSocketPorts=1
  • restart your browser
This should give you back access to the Flash-based chat.

The drawback here is that this is quite cumbersome, in particular for new players... On the other hand, the in-game chat instance is disabled by default, and we should have a new HTML5-based chat client+server soon-ish, right?

Finally, for the curious ones, what apparently happened: a couple weeks ago, a bug was reported to Adobe, with symptoms eerily similar to our current ones. The build was 24.0.0.186 though (which was working fine for us, thank you very much Adobe). The details are at https://tracker.adobe.com/#/view/FP-4198184

Adobe acknowledged the issue and they went on to push out a "patch" a couple days ago, which fixed things for the other guys, but screwed us quite badly. I guess they managed to shoot themselves in the foot and stop themselves from querying whether they were allowed to connect to a server by blocking access to so-called privileged TCP ports, which is exactly what they need in order to ask the question in the first place... (picture me smashing my head on my desk)

I ended up trying the trick that they suggested in that thread, and it worked. Given that Adobe might fix their fix some day, and that we're moving to a different implementation anyway, I'd like to suggest that players use this trick for the time being.
Photo of whbob

whbob

  • 193 Posts
  • 58 Reply Likes
I'm using a mac with chrome broswer. My Adobe Flash is 24.0.0.194...
I can get the site HTML but not the chat.  At the bottom of the chat area, the "open chat window" link can be seen.  If I click on it, everything turns blue where the chat window would be. I can exit chrome and when I open chrome again it shows the web page again with the chat area blank and the chat window link showing again.
Photo of Omei Turnbull

Omei Turnbull, Player Developer

  • 980 Posts
  • 308 Reply Likes
@whbob, you'll probably need to flush your browser's cache.  On Chrome, hold down the shift key and click on the reload page icon.
Photo of whbob

whbob

  • 193 Posts
  • 58 Reply Likes
@Omei: Thanks, that did it :)
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
Working like a charm after a browser refresh. Thanks!
Photo of whbob

whbob

  • 193 Posts
  • 58 Reply Likes
Had logged out of eterna for a few hours.  Logging back in, I had to reload chrome again (with the cursor in the flash area, hold down shift key and right click to bring up a popup menu. select reload) because chat kept flashing "connecting" but never connecting.