EteRNA Medicine Puzzle Progression & Interface Feedback

  • 2
  • Article
  • Updated 4 years ago
The new puzzle progression is now live! We're still working on a few things, but we'd really love your feedback on the latest iteration. Please post feedback, bug reports and any other concerns here

If you experience technical problems with any of the puzzles or with the site you can contact Caleb directly at calebgeniesse [at] gmail [dot] com. For bug reports, but as specific as possible (browser information and screenshots are helpful).
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes

Posted 4 years ago

  • 2
Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
I'm not seeing a clear way to navigate in-site to the new tutorial puzzles when I'm logged in as myself.  LFP6 suggested they're on the main page, but I couldn't figure out how to navigate there either.  The eterna logo points to the lab page.  Turns out though that "Lab Bench" (which I assumed would be the lab page based on its name) points to the main page :D  Anyway, just pointing it out.  Also, I seem unable to get to any messages older than the four most recent.  Just getting an animated loading icon when I click "more messages"

Nice to see the site making some changes :)

edit:  also, nothing happens when I click on the green "1" button that says "nucleotide mixer" on mouseover

also, when I reload or refresh the page of one of the new puzzle progression puzzles, I'm taked back to the first one with no option to skip through or speed back along to the puzzle I left off at

Looks like player puzzles with long titles are able to push the puzzle shave preview thumbnail below the bounds of the white box they're supposed to remain in, encroaching on puzzles listed in the row below

This doesn't look quite right - not even sure if it is supposed to be there http://i.imgur.com/2hYaNM9.png
Photo of Rocketdog42

Rocketdog42

  • 33 Posts
  • 2 Reply Likes
Yes, I'm not understanding this new main page.  The first place it sends you is to the lab and you have to search to get to the puzzles.  
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
@Rocketdog: That's actually the idea! The challenge & player puzzles don't really "do anything" for EteRNA's scientific goals (for the most part), so they're being downplayed.

On the main page organization, see my thoughts about that.
Photo of RedSpah

RedSpah

  • 17 Posts
  • 6 Reply Likes
Formatting on arrows in the front page is broken  http://prntscr.com/a2h79n - I think it's Windows when it should be UTF-8.
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Caleb has been working on this - should be fixed now (although we might move to a different arrow system in the near future).
Photo of RedSpah

RedSpah

  • 17 Posts
  • 6 Reply Likes
Double feedback button - http://prntscr.com/a2hccv
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Fixed now.
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
The title over the tutorial puzzles is "Try Out The New Puzzle Progression". Shouldn't this be something more appropriate for a new user coming in?
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
This is for veteran users.  New users see "Earn ten more tools to start real experiments!"
Photo of Hyphema

Hyphema

  • 91 Posts
  • 25 Reply Likes

I have to reduce the screen size to 50 or 75% to get to the "next puzzle" button on most but not all puzzles.  when I shrink the size down I cant see the energy in the total energy box so I have to increase the screen to 100% then shrink back down to get to the next button.  So far I like the progression

Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
I can't even shrink it enough to see the 'next puzzle' button on some of them, using my laptop
Photo of Meechl

Meechl

  • 81 Posts
  • 27 Reply Likes
I just ran into this problem. http://prntscr.com/a4pp9k
Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
this is still an issue new players are reporting
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Thanks for mentioning this again. I think this is mostly a viewport problem.  The mission screen does not dynamically change size based on the size of the viewport.  The ideal solve would be to make it responsive - not quite sure what it would take to do that, but I can chat with Caleb or Nando to see if that's possible.  The other thing that we can do is to adjust spacing, font size, and picture size to make it work with a broader range of viewports (this wouldn't be a perfect fix, but might be good enough until we move on from flash).  This is a high priority.
Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
Excellent, thanks for address this
Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
I've solved all constraints for supercomputer level 4, but there is no indication I've completed it nor any options for moving on to the next puzzle in the set  http://i.imgur.com/mVFd5Hu.png
Photo of cake

cake

  • 7 Posts
  • 0 Reply Likes
Same as you, Hoglahoo
cannot solve supercomputer level 4
ACAUGAACAUGAGACAUGAGGAUCACCCAUGUGUACAUGAGGAUCACCCAUGUACAUGAGGAUCACCCAUGUUGAGGAUCACCCA is my solution that meets all constraints
MS2 @35-53
Photo of cake

cake

  • 7 Posts
  • 0 Reply Likes
still does not work
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Sorry - this was a script problem.  Should be working now.
Photo of cake

cake

  • 7 Posts
  • 0 Reply Likes
Same as you, Hoglahoo
cannot solve supercomputer level 4
ACAUGAACAUGAGACAUGAGGAUCACCCAUGUGUACAUGAGGAUCACCCAUGUACAUGAGGAUCACCCAUGUUGAGGAUCACCCA is my solution that meets all constraints
MS2 @35-53
Photo of Hyphema

Hyphema

  • 91 Posts
  • 25 Reply Likes
when I am solving puzzles under the "play for fun" I cannot navigate away from the page without having to open a new tab.  pic shows the navigation bar up top is missing http://prntscr.com/a2j8de
Photo of Hyphema

Hyphema

  • 91 Posts
  • 25 Reply Likes
under thermocycler, I think level 5 should be after level 9 to explain the natural vs target mode switch since it is solved similarly.  (I think level 5 is similar but I may be wrong, going by memory)  still like the progression very much.
Photo of Hyphema

Hyphema

  • 91 Posts
  • 25 Reply Likes
I am mistaken, Astromon's pic shows the issue with level 5 on thermocycler.  The information box should say switch between natural and target modes.
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Hi as i see bugs or improvements needed I'll post them here thanks>>>      I have to deselect then re-select  in game chat option for it to open every time i get to the next puzzle!! Thanks!!!!
Also this>>>http://prntscr.com/a2lhqy
Photo of Hyphema

Hyphema

  • 91 Posts
  • 25 Reply Likes
Astromon, thank you, your pic shows the issue with level 5 thermocycler.
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Thanks for this - missing line in the tutorial.  Will fix momentarily.  Just made it move to natural mode in the beginning.
(Edited)
Photo of whbob

whbob

  • 193 Posts
  • 58 Reply Likes
From the home page(...org/web) when I select "just for fun" under side projects, I'm brought to the first puzzle.  The home page button said I had 0% completed.  I actually have many puzzles completed.  I have to go through each puzzle again each time I come back to "just for fun".
Each puzzle has all the bases mutated so all I have to do is change from Target to Natural and I get bubbles so I can continue to the next already solved puzzle:(  In the old format, we had boxes we could check-mark so we could see "All" or "solved" or "Unsolved" if I remember correctly.
Seems like the software is stuck on "All" when we restart the "Just for fun" project?
Photo of cake

cake

  • 7 Posts
  • 0 Reply Likes
Same as you whbob, only that it keeps returning to http://www.eternagame.org/web/puzzle/4350940/ and the 0% completed sign remains at 0%.
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
This is still a problem, and sorry it hasn't been fixed yet.  We're going to adjust how we organize side projects, which should enable us to both get rid of this problem and curate it more easily.  Thanks for noticing this.
Photo of whbob

whbob

  • 193 Posts
  • 58 Reply Likes
http://www.eternagame.org/game/puzzle/6502963/ is too large for my monitor.  Puzzles before this one were sized OK.  New players will have to know how to resize their browser in order to see the selection button at the bottom of the page because the page doesn't scroll.
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Should be working now.  Thanks for reporting.
Photo of whbob

whbob

  • 193 Posts
  • 58 Reply Likes
http://www.eternagame.org/game/puzzle/6502974/ froze on me at 9:00 EST.
Again, I have to start over from puzzle No. 1 :(
(Edited)
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Hi to quickly get back to your progression in the progression puzzles just go to your cleared puzzles in your profile and click your last cleared puzzle!!! (until the bug is fixed)
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
If I understand correctly I think starting over shouldn't be a problem anymore - not sure about the freezing part.  Thanks for reporting.
Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
MS2 stamping tool doesn't seem to be working for me in level 10 of supercomputer

- nevermind, after waiting about ten minutes it is now working. either was very slow to load or ... I dont know
(Edited)
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Hmm... okay.  Yeah, sometimes it's a little slow, but 10 minutes is *way* slow.  I'll bring this up and see what possible solutions might be.
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Hi to quickly get back to your progression in the progression puzzles just go to your cleared puzzles in your profile and click your last cleared puzzle!!! (until the bug is fixed)

Also here is something else about visual problems I'm having in the progression puzzles thanks


http://prntscr.com/a2mzp6
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Hi Astromon - I don't understand this picture I'm afraid.  Maybe you talked to Caleb about it elsewhere?
Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
I've created a new account for testing, and I'm stuck in a loop. Everytime I click "I agree I am 13 or over" then I'm sent to the stanford survey thing. When I decline the survey, I'm taken back to the "I agree I am 13 or over" dialog box.  *Update* I was able to move on by clicking the "I agree to the terms of service"

The "Lab Access" link in the linear puzzle progress graphic points to a blank page

Completing the new puzzle progression doesn't create a white checkmark on baby blue field for the supercomputer level, unlike the previous 9 - perhaps due to the level 4 not properly submitting when solved?

Creating a puzzle doesn't seem to affect the progress bar of the create a puzzle side project. same with creating a script
Photo of mat747

mat747

  • 130 Posts
  • 38 Reply Likes
"The "Lab Access" link in the linear puzzle progress graphic points to a blank page"
Same for me too.
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Some of the other things you mention I think were fixed, but the lab access button still goes to a blank page.  Should be fixed shortly.
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Hi!! here is this bug>>>   http://prntscr.com/a30xfr
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Re: side projects, yep, something is wrong with them still.  Hope to fix it soon.  The funny arrows should be fixed now.
Photo of mat747

mat747

  • 130 Posts
  • 38 Reply Likes
Hi

My Feed page is not working correctly, The "More messages" option is not loading the requested information after clicking the button.
http://prntscr.com/a33840
Photo of Eli Fisker

Eli Fisker

  • 2239 Posts
  • 498 Reply Likes
Same here.
Photo of hoglahoo

hoglahoo

  • 141 Posts
  • 39 Reply Likes
Mine's working now
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
This should be working now.  If it's still a problem, please let us know.  Thanks for reporting.
Photo of Meechl

Meechl

  • 81 Posts
  • 27 Reply Likes
The new lab browser won't load for me. :(

When I try to open it, I just get this: http://prntscr.com/a3e9ik

I have tried on chrome, edge, and firefox with the same result. I am running windows 10, if that makes a difference. 
Photo of mat747

mat747

  • 130 Posts
  • 38 Reply Likes
I`m also running windows 10
Photo of Eli Fisker

Eli Fisker

  • 2239 Posts
  • 495 Reply Likes
Its not loading in windows 7 either. Or rather, it keeps loading.
http://prntscr.com/a4bhgx
Photo of Omei Turnbull

Omei Turnbull, Player Developer

  • 980 Posts
  • 308 Reply Likes
Hi Meechl et al.  My apologies.  There is a problem in that the production Eterna server is using the development server for the new data browser; we don't yet have separate versions for testing and production.  So when I break something during the development process, it breaks for all players, not just me.  

Hopefully things will stabilize before too long.
Photo of Meechl

Meechl

  • 81 Posts
  • 27 Reply Likes
The lab browser is now working! It looks great, thanks, Omei.
Photo of Omei Turnbull

Omei Turnbull, Player Developer

  • 980 Posts
  • 308 Reply Likes
Thanks Meechl. :-)

Be warned that there are many puzzles listed, but only the last round of Exclusion puzzles currently have data available, and even those don't show all the data columns.  I'll post to the data browser topic when there is really something new to see.
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Hi florescent probe 1 and 2 makes no sense to me and can be explained much better imo.
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Happy to take another crack at it.  Can you PM me with potential suggestions?

I think I know one point of confusion - was Fluorescent Probe 1 in PiP mode when you entered?  Trying to fix that.  A point that comes up in another puzzle or two.  As of now the tutorial script can't control PiP mode.  We can fix the problem, just will take a little time.
(Edited)
Photo of JR

JR

  • 241 Posts
  • 20 Reply Likes
Finished all levels with no problem.  The progression becomes dead space after everything is complete. Down the road may want to replace with 2 larger buttons like lab and player puzzles/challenges (if not complete) since that's where players will most likely go. 
 
(Edited)
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
That makes sense.  We were planning on getting rid of the progression on the main page for players who have lab access, but hadn't quite thought out what it would look like.
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
@bekeep: Dashboard? Maybe? :)
Photo of JR

JR

  • 241 Posts
  • 20 Reply Likes
May want a "go back to Main Page" button somewhere.  Top of page LHS of player icon maybe?
(Edited)
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Hi, here is a misspelling in the hint>>   http://prntscr.com/a3mqxj And this   http://prntscr.com/a3rqpb
(Edited)
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Thanks Astromon - fixed the first one.  You're bringing out the grammarian in me for the second, which, IMO, is not a misspelling because the letter 'A' starts with a vowel sound and the letter 'U' starts with a consonant sound (a 'y' sound in English).  I think 'an' is mostly a phonetic helper ('an apple' better than 'a apple', but 'a universe' or 'a U' doesn't need the consonant that distinguishes between the article and the beginning of the word).
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Hi these progression puzzles are so awesome that they have hindered my cloud labs !!! so i want to request a later dead line!!!!   Thanks in advance!!!!!!  :D   :P   :)   (ps I wish to fill all my slots this round)
Photo of Rocketdog42

Rocketdog42

  • 33 Posts
  • 2 Reply Likes
I've finished all the puzzles finally after taking a break to play in the lab.  I see that the new format has been added to eternagame.  Has this been done with all the new things suggested by people and should we go through this new set?
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
yeaH there is much to learn doing the new progression puzzles.
Photo of Astromon

Astromon

  • 192 Posts
  • 26 Reply Likes
Create a tutorial is taking me to a blank white page!!  Thanks!
Photo of LFP6

LFP6, Player Developer

  • 613 Posts
  • 109 Reply Likes
@Rocketdog: Some things may still be in the works, but this (the version on the production site, as opposed to the development site) is what we're commenting on now.
Photo of Rocketdog42

Rocketdog42

  • 33 Posts
  • 2 Reply Likes
LFP6, OK, great.  That's what I thought, but wasn't very sure
Photo of bekeep

bekeep, Learning Researcher

  • 98 Posts
  • 20 Reply Likes
Re: the tutorial taking to a blank page - we're still figuring out how to port the tutorial from the dev site to the prod site.  We're working on it.