Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Eurotherm 2416 Module Not Recognized in iTools

I have a Eurotherm 2416 that is configured in a two-wire 485 configuration. I have been unable to communicate with the 2416 module, and my setup is described below.

The 2416 module is connected to a computer via a USB-485 adapter, and the adapter/module appears under Device Manager as COM11. After connecting the module to the computer, I run iTools and scan for the Eurotherm device. Scan settings are: 1) Scan all device addresses, and 2) Scan for Eurotherm devices only.

In the OPC Scope viewer, I am able to pull up the COM11 baud rate and address values during the iTools scan, and I can see the address increment and the baud rate change. However, the scan will complete without finding any Eurotherm devices.

For troubleshooting, I have alternated the HE/HF (A/B) lines to make sure that there was not a mix-up with the wiring. Further, I have wired a different 485 device (non-Eurotherm) to my USB-485 adapter and was able to successfully communicate with the other device. I have also tried using different 2416 modules, but neither is recognized when scanning.

At this point, I am not certain where the issue lies or if I am neglecting some setting. After verifying that I am able to communicate with a non-Eurotherm 485 device, I believe my wiring/adapter setup is correct. If you have any suggestions about what to try next, it would be greatly appreciated. Thank you very much.
1 person has
this problem
+1
Reply