New P304c - Scada Software can't find it over RS-485

Have a new P304C/CC/VH/xxx/SD4L and trying to setup comms to my PC running Specview SCADA software using an ACCESS I/O serial -usb converter. The software cannot find the unit. Itools also cannot find the unit with the same cabling connection. Is this a fault with the serial cable, or is this unit just not equipped for RS-485, despite being specified as having the capability.? I'm connection Terminal 61 B/B to TDB+ Terminal 60 A/A to TDa - and Terminal 62 Common to Ground. Tried switching A and B, still no comms response. So what can I do with this?
1 person has
this question
+1
Reply
  • Bob Anderson (Technical Support Engineer) November 17, 2014 09:11
    Hello Bill,

    Your coding is correct for the RS485 option.

    In the iTools applet in your PC control Panel have you setup in Registry settings -> Serial Ports your COM port and MODBUS selection.

    Also note, not all serial convertors connect with iTools software, perhaps it is worth checking another unit if you have one with iTools.

    I have noticed chipset FTDI convertors function with WIN7 okay for reference.

    Our recommended converter is the KD485 as shown in the manual, section 1.5.10.



    Please see if any of the above can help you.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • Jon (Official Rep) November 17, 2014 09:17
    Hello Bill,
    Assuming the your USB to Serial RS485 converter is setup ok & it's been assigned a serial port(To check go to Control PanelDevice Manager>Ports ) you then need to open the itools applet within the Windows control panel and make sure the serial port has been enabled - Restart itools and try scanning again.

    Let me know how you get on, Regards Jon
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • I’m happy
    Thanks guys. Turns out the mistake was on my end. Was unaware that this controller setup has the comms disabled as the default. After going thru the Config using the password as the first CODE, instead of putting in the P-Code number for activating Modbus as I did a few times, setting P91 to comms enabled and P92 to Modbus, all is now well with the device. Maybe future issues of the manual could have these setup info-bits closer to the beginning instead of page 56 or so? Usually manuals have the critical "won't work at all without doing this first" information a bit earlier on, to save us going geek-brained from reading the whole manual.........
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated