Help get this topic noticed by sharing it on Twitter, Facebook, or email.

OPC server issues on restart of computer

I have connected a Eurotherm 6180A connected to 2 computers using with itools v.9.79 with OSI PI (OPC DA interface). When I reboot my computer (1 only), PI starts Eurotherm iTools OPC application, but the Eurotherm Generic CSV Instrument Descriptor Module does not start and therefore this cause communication problems (I get no data). Am I missing something in the configuration? when I have the computer up and running and I start the interface manually it works... I can't explain what is happening
1 person has
this question
+1
Reply
  • Hi,

    What Windows user does the OSI PI OPC client start up as when your computer boots? The likelihood is that EuroMBus (the iTools OPC Server) will also be launched as that user. However you may have configured the saved address space (which instructs EuroMBus to load the generic CSV IDM) for a different user (i.e. your user).

    To find out, you can use the Process Explorer (free download from Microsoft - https://docs.microsoft.com/en-us/sysi...) to find that out.

    When you normally run EuroMBus, it runs as your current user. So when you configure a saved address space, it is associated with your user.

    To make EuroMBus also launch with a specific address space for all users by default, use the iTools Control Panel:

    * Under "Windows Start", select "Eurotherm iTools Advanced", then "iTools Control Panel"
    * Select "OPC Server Startup" tab
    * Configure the appropriate Address Space file under "Default Settings"
    * "OK" to close

    In theory, EuroMBus should restart with the desired address space for all users.

    Let us know how you get on.

    Adrian
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Thanks Adrian.

    I am on Windows 10 entreprise.

    The *.UIS file is properly set in the control Panel under "Default Settings
    Our goal is to have the machine to reboot and no user should log in to have all interface to restart.
    This is the case for Eurotherm iTools OPC application, but the Eurotherm Generic CSV Instrument Descriptor Module does not start.
    Is there a Parameter that should be modified in an ini file?

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • We need to confirm that EuroMBus is happy with loading that address space file. To do that, we need to find where it is currently storing the server log file. By default, it stores it in the user's temporary folder - but it need to know which user.

    So the easiest way is to force the log file folder to a known folder - for example, "C:\temp". To do that, launch EuroMBus (iTools OPC Server) as Administrator User:

    * "Windows Start"/"Eurotherm iTools Advanced"
    * Right-Click on "iTools OPC Server"
    * Select "More", then "Run As administrator"
    * Once EuroMBus has launched:
    * Select "Edit"/"Server Settings..."
    * Select "Log File"
    * Under the right column (Local Machine Settings), in the top-right field ("Path to the folder for OPC Server Log File"), add "C:\temp" (or where ever your preferred folder is)
    * "OK"
    * close everything, reboot

    Now once it has rebooted, you should see in "C:\temp" (or your preferred folder). The log file is textual, and should tell you everything it is doing and any issues. Check for anything obvious. If you cannot see anything, please email it to:

    Support.eurotherm.uk@schneider-electr...

    It might be an idea to zip it first. Please feel free to delete any entries which you may feel are confidential (e.g. computer machine names, etc).

    Adrian
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hello Adrian,

    I will Forward the log file to the support mail you have provided, since few lines are showing Errors, that you could may be help with.
    interesting are the following lines
    09:56:10.882 19/07/2019 : System Error : Unknown IDM CoCreateInstanceEx Error 8000401A
    09:56:10.882 19/07/2019 : System Debug : ASSERT Error in 09:56:10.882 19/07/2019 : Client Information : Failed to load IDM for device 10-149-138-32-502-ID255-6180A
    09:56:10.882 19/07/2019 : Client Error : Failed to load IDM for 10-149-138-32-502-ID255-6180A
    09:56:10.882 19/07/2019 : System Debug : Opening existing document C:\Program Files (x86)\Eurotherm\WST303Eurotherm.uis completed
    09:56:10.898 19/07/2019 : System Debug : Reloading IDM
    09:56:10.898 19/07/2019 : System Error : Unknown IDM CoCreateInstanceEx Error 8000401A
    09:56:10.898 19/07/2019 : System Debug : ASSERT Error in 09:56:10.898 19/07/2019 : Client Information : Failed to load IDM for device 10-149-138-32-502-ID255-6180A
    09:56:10.898 19/07/2019 : System Debug : Reloading IDM completed
    09:56:10.945 19/07/2019 : System Debug : Loaded IEurothermAuthorize successfully
    09:56:10.991 19/07/2019 : System Debug : 1 Client Connected

    not sure if I missed a setting
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • That error code means "The server process could not be started because the configured identity is incorrect. Check the username and password".

    Perhaps you need to associate EuroMBus with a specific user, rather than let it be run as system defined user - which may have restrictions applied.

    There is a technical note on running EuroMBus as a service. You probably do not need the service bit, just the associating EuroMBus with a known user. Details are as follows:

    iTOOLS OPC SERVICE

    The sole purpose of this service is to allow the iTools OPC Server to
    run at system startup, or at any time when no user is logged in.
    In effect, the iTools OPC Server will itself be running as a service.

    Some manual configuration steps are required to ensure that the iTools
    OPC Server can run with no user logged in. This is the recommended
    approach: -

    1. Create a new user on the system, giving it an appropriate name,
    e.g. "itools" or "opc". This user should be made a member of the
    Administrators group. You may wish to setup the computer's
    Security Policy so that this user is unable to login to the
    computer either locally or remotely.

    2. Use the DCOM Configuration utility (DCOMCNFG) to specify that the
    iTools OPC Server (identified as "Eurotherm Modbus OPC Server"
    should run under this new user's account, rather than as the
    "interactive user" or the "launching user". The same change should
    also be made for the "Eurotherm iTools Authorization Server".

    3. Use the Services admininstrative tool in Windows to enable the
    iTools OPC Service, and run it as appropriate.

    For more information on DCOM configuration for OPC, see the whitepaper
    "Using OPC via DCOM with Windows XP Service Pack 2", available from
    OPC Foundation at http://www.opcfoundation.org/DownloadFile.aspx?RI=326


    Hope that helps,

    Adrian
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hello Adrian,

    Picture enclosed, this was properly set.
    Any idea, what else to check?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • As it is the Generic CSV IDM which is having issues, might be good to check that also has the same settings.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hello Adrian,

    You rock! this was the issue the Generic CSV IDM in the DCOM was not set to "this user"

    Thanks alot!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • EMPLOYEE
    I’m happy
    Fantastic!!

    Will investigate at our end to try to understand why...

    Thanks for contacting us - if you have any other questions, please let us know.

    Cheers!

    Adrian
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • EMPLOYEE
    I’m happy
    Actually I think there is already a tool in "Eurotherm iTools Advanced" called "iTools DCOM Settings Removal" which clears out all those DCOM settings.

    I suggest as your system appears to be working now, to not try running this tool - "don't fix what ain't broke"...

    Adrian
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated