Help get this topic noticed by sharing it on Twitter, Facebook, or email.

RSLogix 5000 Generic Ethernet Module faulted status code 16#0117

I am connecting an EPack 2 Phase over Ethernet to RSLogix5000 (L71). I configured a Generic Ethernet Module as outlined in the user guide. I get a faulted status, code 16#0117 -- Connection Request Error -- Invalid connection point. I followed the user guide instructions. Configured the Input Instance 100 and size 10. Configured the output Instance 150 and size 2. Configured the Configuration Instance 5 and size 0.

I think the comm connection is good, if I reset the module in RSLogix, the Epack 2PH restarts.
1 person has
this question
+1
Reply
  • Jon (Official Rep) May 24, 2019 07:04
    Hello Herb,
    When defining a generic profile for the EPack, the name of the device has to end with a number. If this is not done, the device is not included to the communication later. Further on, a minimum poll rate of 100ms is mandatory. Otherwise no communication to the EPack will run. The instances for input and output have to be set to 100 and 150. The instance for configuration is normally not used (so the value is 0 byte). But if the value is different to 199, the configuration is not valid and again, the communication to the EPack will not run. So please set to 199.

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Made the changes -- set Configuration Instance to 199 and poll rate to 100 ms. and this corrected the invalis connection point error.

    I now have new error, 16#0127 - Invalid output size. I have tried 16, 32, 2 and 4 for the output size.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned