I am running Windows ME,can I download an older version of Flock?

  • Question
  • Updated 6 years ago
Photo of George Filchak

George Filchak

  • 1 Post
  • 0 Reply Likes

Posted 6 years ago

  • 3
Photo of Patricia

Patricia

  • 668 Posts
  • 52 Reply Likes
Hello George,

I apologize for the late reply. I would like to know whether there are some special reasons for requesting an older version of Flock.

Thanks,

Patricia
Photo of Rita KuntzRK

Rita Kuntz

  • 2 Posts
  • 0 Reply Likes
DUH!! Not everyone owns a computer with the latest operating system or can afford to buy a new one. My operating system is Windows ME, so I need something that is compatible with Millennium Edition, please. How can I download Flock 2.0?
Photo of

  • 60 Posts
  • 11 Reply Likes
Rita, click on Flock 2.0.3 (23-Dec-2008) below in this page. The install file is flock-2.0.3.en-US.win32.exe 23-Dec-2008 19:04 12M. You can find versions in other languages in the I10n directory.
Photo of Rita KuntzRK

Rita Kuntz

  • 2 Posts
  • 0 Reply Likes
After I installed 2.0.03, got Error message, need Windows 2000 or higher (it does NOT work with ME, Millennium Edition)
Photo of

  • 60 Posts
  • 11 Reply Likes
I'm sorry, Rita. Any Flock older than version 2.0.3 or Firefox older than version 2.0.0.20 is a security risk. Please find my answer below in this page.
Photo of

  • 60 Posts
  • 11 Reply Likes
The latest Mozilla web browsers that runs on Windows 98/Me are Flock 2.0.3 (23-Dec-2008) and Firefox 2.0.0.20 (18-Dec-2008)
Photo of

  • 60 Posts
  • 11 Reply Likes
Firefox 2.0.0.20 (and Flock 2.03) is affected by several vulnerabilities fixed in newer versions of the program.

http://www.mozilla.org/security/known-vulnerabilities/firefox20.html

http://www.mozilla.org/security/known-vulnerabilities/firefox30.html

Flock 2.5.2 user agent is (Windows XP): "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13) Gecko/2009080717 Firefox/3.0.13" Then, it is like a Firefox 3.0.13 (31-Jul-2009)

There is another Firefox, the 3.5.x Series, which already has its own history:

http://www.mozilla.org/security/known-vulnerabilities/firefox35.html
Photo of

  • 60 Posts
  • 11 Reply Likes
This site's name is Get Satisfaction, so hope who administrate it does no bury this post.

What you need is Opera.

Minimum configuration for Opera:

* 20 MB of free disk space
* Any system running Windows 95 (or later)

P.S.:

Windows Me is a security risk too, hope at least your system has a firewall. Maybe you have a friend or know someone who can help you to upgrade your system without spending money.

Sometime ago I bookmarked the site "Windows Millennium Edition (Me) essential free upgrades + fixes", maybe it interest you.

If you search the web (Windows XP for old PCs) you can find tricks to run Windows XP on machines having low system resources.