Buy links not appearing in my browser.

My site is www.gjim.com (http://wyomerc.com/g-jim_photography).

The buy links are not appearing, to me, although many of my friends state that they can see them. I have tried Firefox, IE, Avant, Chrome, Opera - same issue in all these browsers. I have java-scripts enabled - must be some sort of security setting somewhere.

I'm not all that concerned that I can't see the links, but if a potential customer might have the same issue I would like to put a note on the site as to how to correct the problem.

There is a small chance that this is somehow related to my ISP. I live full-time in an RV, traveling around the country, thus I use Starband for my internet service.
1 person has
this problem
+1
Reply
  • Derek (Official Rep) August 13, 2012 19:33
    Hi Jim,

    Thanks for contacting us about this. I took a look at this page and was able to see the Buy Buttons, so Fotomoto is working. Hopefully that's the case for all of your customers as well =)

    I suspect there might be a plugin or something specific to your browser that might be causing the issue, and I'd love to know what it is if that's the case.

    So, could you try using another browser? Or, if you're using Chrome try loading the page in "incognito mode". If you're using another browser I'd suggest disabling all the plugins/add-ons and check to see if that helps. If so, then it will be possible to re-enable plugins/add-ons and see which is the culprit.

    It's also a possibility that there's a network connectivity issue, but much less likely than the above.

    I hope that helps and let us know if you need more assistance here.

    Kind regards,
    Derek
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • This really does appear to be an issue with the Starband satellite internet connection.

    I used my laptop, connected to Starband - same problem that I'm seeing with my tower machine. Used the laptop, without changing any settings, connected to a Wi-Fi system - the buy links appeared along with the photo(s).

    Is there some sort of timing issue within that Java-script that doesn't like the latency inherent to the satellite system?

    Jim
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Derek (Official Rep) August 15, 2012 08:45
    Hi Jim,

    This is an interesting question that I'm going to need to research the answer to. It might take me a while but I'll get back to you as soon as I can on this.

    Thanks in advance for your patience and kind regards,
    Derek
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Derek (Official Rep) August 15, 2012 17:34
    Hi Jim,

    Given the testing you've done it sounds like your theory about the satellite connection being the issue is plausible. If Fotomoto doesn't work on a computer connected by satellite but does work consistently on the same computer connected to Wi-fi, then you've likely found the issue. Satellite connections are often interrupted from what I understand, and Fotomoto does need a stable connection to work.

    The good news is that Fotomoto seems to be working fine on your site, so your customers that have stable connections should be fine. Please do get back in touch though if you have other reports of something not working - we'll be happy to look in to it for you.

    Kind regards,
    Derek
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned