I’m sad, confused, frustrated, can't get it to work, tried all kinds of things, hoping there is a solution, will be immensely helpful if resolved and greatly appreciated!

Fotomoto With Folder Image Gallery Plugin

Hello,

Two issues:
Buttons would not show up on lightbox (I tried several)
Images would not show up on FotoMoto Dashboard

I have a gallery using the Folder Gallery plugin from https://wordpress.org/plugins/folder-.... This plugin is compatible with various lightbox plugins (LBPs). From Folder Gallery you can select one of the compatible LBPs installed. I've tried all sorts of things to get FotoMoto working with some of the supported LBPs including specifying no LB plugin from the FotoMoto. Here is a link to the page I am working on.

http://photolish.com/brenes-16th-birt...

Folder Gallery supported LBPs I was able to make work:
Easy Fancybox Plugin
Responsive Lightbox Plugin

The best I can do was get the FotoMoto links to show up on one of the LB image. And, even though I navigate to subsequent images, clicking on the Buy Print links show the first image in the FotoMoto store.

I'm thinking this is because FotoMoto looks at the page before the plugin loads the images - is there a way to trigger FotoMoto after some hook or event on the page. Or is there a known solution to this?

Attached image shows FotoMoto on background image but not LB image.



Thanks!
1 person has
this question
+1
Reply
  • Derek (Official Rep) May 03, 2016 11:59
    Hi Victor,

    Thanks for your post and helpful screenshot! I'm happy to help you however I can here.

    So I looked at your page, and can see that the Buy links were showing under the single image at the top without a problem, but they were not showing correctly in the fancyBox. I saw that your Script Library setting was set to "None..." and would need to be set to "Fancybox" in order for Fotomoto to work with fancyBox. So, I went ahead and changed that setting for you, and now (as expected) the Buy Buttons do not show below the single image, but they do appear when you click the thumbnail in the fancyBox.

    Trouble is that with fancyBox we "pin" the Buy links to the top of the page (since we don't have a way to properly detect the images in fancyBox), and your theme's header was covering the Buy links. I used my browser's developer tools to set the header to "display:none" and took a screenshot so you can see that they are actually there.

    So to get the trouble solved, the first thing we need to know is how you'd like the images to be dislpayed...do you want to use fancyBox or would you prefer to just insert multiple single images or maybe even Juicebox or Foobox, which are also supported and a bit more "modern" looking?

    Let me know on that and I'll be happy to help with the next best step.

    I hope that helps and kind regards,
    Derek

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I think this is great news. I'm going to try and set the styles to position the FotoMoto btns on the light box correctly. Will get back to this thread with further issues.

    Thanks!

    Vic
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated