Help get this topic noticed by sharing it on Twitter, Facebook, or email.

How do I use Fotomoto with the NextGEN Gallery plugin for WordPress?

Tested with:
NextGEN Gallery version 1.9.3
WordPress version 3.3.1
Twenty Eleven 1.3 theme

Fotomoto is compatible with NextGen Gallery, but will not work with certain options.

Known issues
Fotomoto is not compatible with the following NextGen options:

  • JavaScript Thumbnail effects: Lightbox, Highslide, Shutter

  • PicLens/CoolIris

  • Slideshow

  • Flash Slideshow



Installation Instructions
To link NextGen gallery thumbnails to the ImageBrowser where the Fotomoto Buy Buttons will be shown under a larger image:

  1. Install the Fotomoto plugin for WordPress using these instructions

  2. Go to your WordPress Dashboard > Gallery > Options > Gallery and enable the "Show ImageBrowser" option



Alternately, to link NextGen gallery thumbnails to the larger lightbox view of the image using a JavaScript Thumbnail effect:

  1. Install the Fotomoto plugin for WordPress using these instructions
  2. Go to your WordPress Dashboard > Gallery > Options > Effects and set JavaScript Thumbnail effect to either "Thickbox" or "None".

  3. If not using Thickbox, install a WordPress plugin that uses a JavaScript library that's in the list of compatible libraries.

  4. Follow the instructions to change the Script Library settings in your Fotomoto Dashboard.

1 person has
this question
+1
Reply
  • I found a bug with Fotomoto/NextGEN galleries:

    1. Go to: Settings > Reading Settings
    2. Make the "Front Page" the page with the NextGEN galleries

    (Bug) At this point the Fotomoto widgets do not appear

    3. Go to: Settings > Reading Settings
    4. Make the "Front Page" any page other than the NextGEN galleries page

    At this point the Fotomoto widgets appear

    I looked at the source for both of these cases. The fotomoto javascript is missing from the "Front Page" scenario.
    • Derek (Official Rep) March 09, 2012 20:05
      Hi Raul,

      I don't think this is a bug - I just tried this on one of our test sites and everything works as expected. You might check the Pages tab at WordPress Dashboard > Settings > Fotomoto to make sure Fotomoto is enabled for the page.

      Otherwise feel free to email us the URL for the page in question and I'll be happy to explore this further with you to see what might be happening.

      Thanks for the feedback and kind regards,
      Derek
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Hi there,

    We are trying to make this work but we haven't had any luck. We have installed and set both NextGen and Fotomoto following these instructions (using NextGen's Thickbox), but the Fotomoto toolbar does not appear anywhere.

    Using the web inspector, the div tags for Fotomoto are all marked with "visibility: hidden" and the toolbar appears located with "margin-top: -1000px" and "margin-left -1000px".

    Any idea how to fix this? The URL is http://ita-liana.com/gallery/.

    Thanks!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited