https issue - fotomoto widget now blocked

Just upgraded my site to https, but now browser is blocking the fotomoto script reference, which is an http url: http://widget.fotomoto.com/stores/scr....

Since I use Turning Gate galleries, I assume this script is laid down during the web gallery creation process using their coding. If I edit it after the fact to https://widget.fotomoto.com........etc. will it still work?

Or is there another solution to this problem.
1 person has
this problem
+1
Reply
  • Derek (Official Rep) January 14, 2017 01:12
    Hi RW,

    Sorry to hear about the issue! I'm not sure of your website URL, so it will be hard for me to check, but I think you've been using Fotomoto for quite some time, and it's possible that it contains the older, non-HTTPS-compatible version of the Fotomoto Script.

    I believe Turning Gate's galleries have all been updated to use the new version of the Script, but I'd like to double-check your site to be sure, and if something needs to be updated I'll be happy to coordinate with TTG to make sure your site and any others out there are updated as necessary so that you can use HTTPS.

    So, please either post your site URL here, or email us directly with the URL...either way I'll be happy to help you get everything working again.

    Kind regards,
    Derek
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated kidding, amused, unsure, silly

  • Hi Derek,

    Thanks for the reply. Yes, I have been using fotomoto for some time. The url is: https://wheelerimaging.com/printgalle...

    However, I did succeed in a work around. I edited the Turning Gate CE4 Gallery web engine - changing the "http" to "https" in the fotomoto url I located inside the one of the files in the engine package. This seems to work, as galleries now created do allow the button script to work. The url referenced above shows the problem, as it was created before I made the fix.

    I am using the latest version of the CE4 Gallery web engine (v6.1.10 - 08-08-16) and it still uses "http", rather than "https". I know Matt has now developed Backlight, so CE4 is not current anymore.

    My work-around only works for me, of course. Not sure if others have encountered this problem as well.

    Posted about his on Turning Gate forums as well, and narrowed down the fix to what I explained above.l
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated kidding, amused, unsure, silly

  • Just checked my url above, and I see the widget does work. So I am confused.
    Perhaps http is OK after all.

    Will have to experiment more, but if you have a solution, or any information for me, that would be helpful.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated kidding, amused, unsure, silly

  • Derek (Official Rep) January 14, 2017 08:05
    Hi RW,

    I took a look at your site and regarding the HTTPS, the Fotomoto Script should be appearing in your page as below...note that the address of the script should not have "https:" in it, rather just the two slashes before the widget.fotomoto part.

    If Javascript is disabled in your browser, to place orders please visit the page where I sell my photos, powered by Fotomoto.

    After looking at your site and account I have a few suggestions for you, so I'll email you those directly.

    I hope that helps and kind regards,
    Derek
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated kidding, amused, unsure, silly