Multiple Photos in a Single Word Press Post, Buttons show up for some not others.

Is there a trick to getting this to work. I'm using the ProPhoto wordpress template, not cheap I know. Anyway, to my dismay, fotomoto works great with it except for this problem. If you post a number of photos in one single post, the "sale buttons" will show up on some photos and not others. After refreshing several times the showed up for all but one of the photos in a 6 photo post. I looked at the HTML behind the post and every thing is identical. I also took that photo and made a single post out of it to test, and the buttons show up fine. What gives? Any ideas?

=Neil
1 person has
this problem
+1
Reply
  • I broke the six image post into 2 posts of 3 images and it's working like a charm. I was a bit frustrated, but in reality the two smaller posts look better and make it more feasible to work with especially from a social network sharing perspective. Love the Fotomoto plugin, keep up the great work. I hope maybe some one else who ran into this problem will find this helpful.

    take care

    -Neil
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Okay I'm back, because I wanted to share since I spent another hour tracking down the issue. After splitting the original 6 photo post into two posts of 3 each and preferred it that way, I still couldn't accept that I couldn't figure out what the issue was. Well, I did, if you are using ProPhoto as a word press template, which is amazing by the way, worth every penny, anyway, there is a feature called "lazy loading" under the "text & image" options under the "content appearance" sections of the customization options. What it does is make your site load faster as it will only immediately load the images that will appear in your browser upon loading. So if you have a blog with a ton of large images that you have to scroll down to see, it just loads them as you scroll instead of trying to load them all at once. Well, when you're using the Fotomoto plugin, this delay in loading can throw off the "buttons" for Fotomoto appearing near your photos below that were "waiting" to fully load. If you turn this option off, the Fotomoto plugin works just fine you can put as many photos in a single post as you want.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Derek (Official Rep) August 24, 2012 05:34
    Hi Neil,

    Thanks for your post, and it looks like you answered your own question...nice work! You are exactly correct - if you have "lazy loading" enabled, our Script won't be able to properly detect all the images as expected, thus you won't see the Buy Buttons for some images. You're also correct that disabling lazy loading is the only way to make Fotomoto work as expected with all of your images.

    ProPhoto is a fine theme, it's just that not all options are 100% compatible with Fotomoto at this time. We'd be happy to work with the developers of ProPhoto to make their theme 100% compatible, otherwise we can only suggest that you disable lazy loading or use one of the themes recommended in our list of compatible themes.

    If there's anything that we can help you with please feel free to post back, otherwise we hope you enjoy using Fotomoto and kind regards,

    Derek
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited