Unable to embed

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
I am unable to embed the map created by imapflickr into my Wordpress blog using the code generated by the site. All it does is to create an iFrame and in the iFrame is not the map, but my site.
Photo of Saigo

Saigo

  • 3 Posts
  • 1 Reply Like
  • sad

Posted 7 years ago

  • 1
Photo of Darren James

Darren James, Technical Director

  • 45 Posts
  • 3 Reply Likes
We've not seen this before Clement. Can you please post your blog address and the imapflickr URL (http://imapflickr.com/[something]/) you are trying to embed and we'll take a look?

If you don't want to post your blog address, you can email me direct at darren.james [at] framecreates [dot] co [dot] uk
Photo of Colin Wiseman

Colin Wiseman, Official Rep

  • 36 Posts
  • 1 Reply Like
I have done a search, and some WordPress WYSIWYG editors strip out the iFrame code when using the HTML view. Other WYSIWYG allows the iFrame code happily, tested on an friend's blog.

There is a widget you can plug into your website:

http://wordpress.org/extend/plugins/e...

that should help, if you have access to the directory structure. But please contact Darren at the above details if you require more help.

Thanks
Photo of Colin Wiseman

Colin Wiseman, Official Rep

  • 36 Posts
  • 1 Reply Like
Hey Clement,

Could you do me a favour and embed your map into the blog, and send me a link to the page? colin [dot] wiseman [at] framecreates [dot] com

It's a strange one this. We have also started to look into creating wordpress shortcodes to see if that would help, but we aren't php develoeprs and php scares me :D

Cheers
Photo of Darren James

Darren James, Technical Director

  • 45 Posts
  • 3 Reply Likes
hi Clement,

Many thanks for posting the example, we've identified the issue and are fixing it just now. Just out of curiousity, are you using a mac or PC?

We'll notifiy you immediately once the problem has been resolved, it should only be an hour or two.
Photo of Colin Wiseman

Colin Wiseman, Official Rep

  • 36 Posts
  • 1 Reply Like
Hey Clements,

Right think we have spotted the problem. Could you try the following:

<div>
<iframe src="http://imapflickr.com/aa27ab"
height="486"
width="742"
frameborder="0"
scrolling="no"
style="border: 0px;"
border="0"></iframe>
</div>

instead of the one given to you by the site? You will notice the difference is single quotes to double quotes. The wysiwyg editor you use transmoggyrified the single quotes into the other single quote that sit at an angle, and then that was translated into the html hex equiv ’. Basically things went BOOM!

Let us know how you get on so I can then update the live site.

Thanks

Colin
Photo of Saigo

Saigo

  • 3 Posts
  • 1 Reply Like
Hi Colin,

I tried changing it using the code you described, but the same problem still persists. I tried clearing my cache too but to no avail.

Yeah I noticed the single quotes beforehand and thought it was odd as well.

Darren,

I'm using a PC and Firefox is my default browser.
Photo of Colin Wiseman

Colin Wiseman, Official Rep

  • 36 Posts
  • 1 Reply Like
Hi Clement,

Ok this is getting a bit confusing. A few things to try:

1. http://imapflickr.com/saigoheiki-test...
2. http://imapflickr.com/saigoheiki-test... has the source code for the page so if you cut and paste directly.
3. There is a <div> wrapping the iframe. Take that out as well to see if that changes things?
4. This is an extreme one...are you able to create me a login to your blog, so that I can test it and see what is happening? Or could you give me more details of your word press instal? (version, wysiwyg editor name and version)

Thanks for your time on this,

Colin
Photo of Saigo

Saigo

  • 3 Posts
  • 1 Reply Like
Hey Colin and Darren,

I managed to get it working finally! It was funny though. The code that was initially generated was something like this:

And that seemed to do the trick. I have no idea why this is so, but well, it works, lol. I was comparing the codes between imapflickr and mypicsmap, and mypicsmap's code was in a single line, and since it seemed to work with mypicsmap and not imapflickr, I simply replicated its "properties".

Thanks for trying to solve my problem guys,

Clement
Photo of Darren James

Darren James, Technical Director

  • 45 Posts
  • 3 Reply Likes
glad its sorted Saigo - hope you like the new enlarge image feature to!