How can I control the crop on front page images?

  • Question
  • Updated 3 years ago
Is there any way to control how the post images are cropped when they are put on the front page? It seems to always crop on the center of the image. The problem is if you have an image that is a portrait it will only show the person's stomach! Any ideas on how I can fix this? I probably need to control it on a per-image/post basis. For example, I think pictures of people need to be cropped at the top while others can usually be cropped in the center as you already do. So maybe a flag is needed on the post that specifies where to crop the thumbnail. Is this possible in any way?
Photo of

  • 5 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 34
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
Have you tried using the WordPress image editor, to adjust the thumbnail crops? More info. Make sure to only edit the THUMBNAIL size. Otherwise, you’ll end up cropping everything.
Photo of

  • 5 Posts
  • 0 Reply Likes
Thanks for the super fast reply Alan! I have tried editing the THUMBNAIL crop using the WP editor. I make the thumbnail a square but it is still being cropped more when displayed on the front page. Do you have any guidelines? Also if I am not using the Gallery view on the front page, each image has a different aspect ratio so I am not sure if adjusting the thumbnail would help in that case. Am I missing something? Thanks again for the help. I look forward to getting this corrected. I love the theme!! But I do a lot of portraits and want to display them too.
Photo of Samuel Sparrow

Samuel Sparrow

  • 22 Posts
  • 0 Reply Likes
Can anyone please help?
Im trying to sort my picture grid using Autofocus Pro. My grid was aligned correctly using the free version. However, since moving to the pro version it looks like I have missing posts on my front page.

Any help would be great.
Here's my site

http://www.sparrowandco.com/blog

Sparrow and Co
Photo of bstephens

bstephens

  • 1 Post
  • 0 Reply Likes
I also have this problem and have tried using Scissors to crop the thumbnails, but it seems like Autofocus uses the same picture for both the front page and the post?
Photo of dlim98

dlim98

  • 10 Posts
  • 0 Reply Likes
I also had this question on controlling how the images in the front page are cropped. Thanks
Photo of butterfloh

butterfloh

  • 3 Posts
  • 0 Reply Likes
OK, this suggestion doesn't work. That is because for the portfolio template and the squares the real picture is being used, not a thumbnail. So no matter what I do to the thumbnail, even if it looks just the way I want it to look, the main page still is messed up.
So, only choice - have to rewrite the code.
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
This will be fixed in the upcoming update.
Photo of syl

syl

  • 1 Post
  • 0 Reply Likes
Any update on when we could see a release which let us crop the image on the front page?

Thx and great work on the theme btw!
Photo of butterfloh

butterfloh

  • 3 Posts
  • 0 Reply Likes
Personally, I think this sucks. I bought this theme in hopes of getting more control, but I am stuck with a design which leaves my blog looking ridiculously unfinished. I cannot use it the way it is. An update was promised but nothing happened.
Don't get me wrong, I really like the design, otherwise I wouldn't have bought it, but at the moment all I can do is just use the old version, but that's not what I bought the pro version for. I wouldn't say a word if I was still using the free version...
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
Hi Butterfloh,
I’m sorry your having problems with theme and that the update has been taking so long. I want to make sure that the next update is as useful and bug free as possible which is taking longer than I expected. The update is being worked on very close to a stable release.
Photo of Stu Willis

Stu Willis

  • 6 Posts
  • 1 Reply Like
This is great news.
Photo of Ruel Calitis

Ruel Calitis

  • 3 Posts
  • 0 Reply Likes
Hi, Allan

Thank you so much for excellent work on this theme. I'm really new to this technology, I have a version 1.5.4 installed- is there any way I can update it to 1.6 version by simply click update just like the wordpress?

Sorry for my ignorance. Great community btw.

Cheers,
Ruel
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
No, you’ll have to use FTP to update the theme...
Photo of butterfloh

butterfloh

  • 3 Posts
  • 0 Reply Likes
Well, alright then. I didn't mean to unload it all on you, it's just that I had thought of doing it myself, but given the fact that I have no time to do this right now it felt alright to buy a good looking one. And as then there were problems with the thematic theme etc. I just got a bit frustrated because I had to put everything on hold. But great that you're working on it, I really appreciate it!
Photo of dlim98

dlim98

  • 10 Posts
  • 0 Reply Likes
Any updates on how to do this? I want to be able to choose what part of my picture is cropped for the featured image on the homepage. Thanks.
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
Hi DLim98, Currently only the thumbnails in the Portfolio layout can be custom cropped. I believe the core WP guys are working on a way to use the cropping on custom image sizes like the ones used in the featured area.
Photo of jonasiano

jonasiano

  • 3 Posts
  • 0 Reply Likes
Hi,
When trying to crop a thumbnail inside the WP , I choose the area to crop, but the 'save' button is not available.
What am I doing wrong?
Every image is a 1000x650 JPG.
Thank you and sorry for bothering. I'm very new in this.
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
Here’s a tutorial: http://goo.gl/kS28Z
Photo of jonasiano

jonasiano

  • 3 Posts
  • 0 Reply Likes
Uff. I'm a little embarrased here. Thank you very much, Alan.
Photo of Kyle Giesbrecht

Kyle Giesbrecht

  • 5 Posts
  • 0 Reply Likes
Hi, I'm having trouble with this as well. I am wanting to use flickr to host my photo's, but they don't crop properly on the home page. If I put them as a sticky in the featured area, they look great, but the regular posts don't work.
I have also tried to upload just one photo, so I can use that as the featured image, but it seems that once I have added the flickr, it won't pull my featured image. Here is a screen shot. Or you can view my blog at www.handswe.at
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
Hi, Try upgrading to the latest version of AF+ (version 1.5.3). More info:
http://fthrwght.com/autofocus/#faq
Photo of Kyle Giesbrecht

Kyle Giesbrecht

  • 5 Posts
  • 0 Reply Likes
That's the one I'm using. I just upgraded last week.
Photo of Kyle Giesbrecht

Kyle Giesbrecht

  • 5 Posts
  • 0 Reply Likes
Also, you will notice, if you visit the blog, when you mouse over the snaring river image, there is what looks like an error message that appears as a silhouette on the blue background.
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
I just looked at your style sheet in the live link you sent and your still using version 1.5. You’ll need to upgrade to 1.5.3 which should fix the error message as long as your Flickr credentials are correct.
Photo of Zoo Futur

Zoo Futur

  • 2 Posts
  • 0 Reply Likes
Why it's impossible to use the "crop thumbnail" and the "Flickr set box" at the same moment ???

Thk U

My site : zoo-futur.com
Photo of Alexander Jordan

Alexander Jordan

  • 6 Posts
  • 0 Reply Likes
I have problems with an image on my Grid view showing colors on the sides. I've tried resizing and loading a larger image, cropping the thumbnail, and running thumbnail regenerator after selecting a square 188*188 size. Still, the thumbnail of the featured image does not fill the grid window. Most of the other photos have been imported from Flickr. Some of those are cropped. I wouldn't mind it if the photo was cropped, just so long as the border wasn't there! What do I do?
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
Do you have a live link, Jordan? Also, can you please keep the language here PG. I’m sorry your frustrated, but yelling and throwing around obscenities will not help me or anyone else fix your problem.
Photo of Alexander Jordan

Alexander Jordan

  • 6 Posts
  • 0 Reply Likes

My difficulty has been with featured photos loaded from the Media Library. I was able to solve my immediate problem of the colored border by loading the picture from Flickr instead of the media library. Cropping and thumbnailing works with the imported pictures.
Here's my link:
alexjordancarpentry.com
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
I’ll need to see an instance of where the thumbnail crops aren’t working to determine what this issue is.
Photo of ryjones83

ryjones83

  • 14 Posts
  • 0 Reply Likes
Hey everybody - there is (sort of) a workaround for this.

After disabling Feature-Images to be shown in the post by default (delete line 461 from 'thematic-functions.php' to do this), you can crop your photo as you like with an external program (e.g., Photoshop or the like), upload that photo, and set it as the feature image.

This way, that cropped photo won't be shown in the post, but it will be featured on the front page with the proper cropping, and still attached to the post it was set to be 'featured' in. (Just be sure to make the image large enough so it fills the slot on the front page)

Hope this helps.

~Mahalo
Photo of Lars

Lars

  • 4 Posts
  • 0 Reply Likes
I have the same problem and this solution would be perfect.
How and where do I find "line 461"? New to this so I'm totally lost...
Photo of Jennifer

Jennifer

  • 3 Posts
  • 0 Reply Likes
Hi, in my file functions.php there are only some 140 lines. Am I in the wrong file maybe?
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Reply Likes
You’ll need to find thematic-functions.php which is located in the /extensions/ folder.
Photo of allurspam

allurspam

  • 10 Posts
  • 0 Reply Likes
This seems like a good solution, but I can't figure out which line to comment out. Probably because I'm not using the pro version (just started playing with it yesterday). Can I get a little help? The actual text of the line would be great.
Photo of ryjones83

ryjones83

  • 14 Posts
  • 0 Reply Likes
The actual line text is ""
Photo of allurspam

allurspam

  • 10 Posts
  • 0 Reply Likes
Ok, thanks, but I didn't realize it would be such an oft-occurring bit of code. Going to need a few of the lines around it too, if someone would be so kind.
Photo of ryjones83

ryjones83

  • 14 Posts
  • 0 Reply Likes
It's a single line: 461. It's the only code on that specific line, I do believe.
Photo of allurspam

allurspam

  • 10 Posts
  • 0 Reply Likes
There is no line 461 in my thematic-functions.php, probably because I don't have the pro version. I need the block of code is so I can find it as it exists in whatever version of the file I'm using. Mine only has ~420 lines.
Photo of Jens

Jens

  • 4 Posts
  • 0 Reply Likes
WP 3.1 / Autofocus Pro+ 1.6 / Staggered View

Hello,
I create a proper fitting crop image for the front page in photoshop. Basis was the automatic crop image created by WP. While this is rather too much manual work to do it often it works. You have to find out the exact measurements and position of the visible content and recreate a new crop image from the original (I got the crop detail from the CSS).

Unlike Mahalo I don't have any problems with the photo being displayed incorrectly in the post. The post shows the original photo and not the crop.

Hope this helps
Jens
Photo of grant.huntington

grant.huntington

  • 3 Posts
  • 1 Reply Like
WP 3.1 / Autofocus Pro+ 1.6 / Staggered View

Hi Alan, the staggered view worked perfectly in the original AutoFocus 1.0.1 theme, but does not well for me at all in either of the Autofocus + versions.

Do you have an update on this? I purchased the Autofocus + Pro so that I would be able to link youtube videos among other things. I will just continue to use the original Autofocus 1.0.1 until that gets sorted out as the staggered view is one of the key points of this theme, in my opinion. Thanks

Autofocus 1.0.1


Autofocus + Pro 1.61
Photo of greg edgell

greg edgell

  • 11 Posts
  • 1 Reply Like
:: sits patiently waiting for update ::
Photo of grant.huntington

grant.huntington

  • 3 Posts
  • 1 Reply Like
Ok, I just uploaded larger images and that seemed to fix my issue.

It's likely that others have a different problem than I do. Sorry if I went off track from the original question. Cheers.
Photo of Jennifer

Jennifer

  • 3 Posts
  • 0 Reply Likes
I tried that also and regardless of how much I optimezed my pictures the page load is effected by this.