Picture "fade in" instead of "progressive loading" on front page.

  • Question
  • Updated 4 years ago
Hi Allen, hi AF-lovers,

Is there a way to control how images on the front page are loaded?

The newest version of AF seems to make the images "fade in". I am using a modified version and the images somehow load like progressive JPEGs (read: the default background for images is shown and the picture loads top-to-botom revealing more of the image line-by-line). Depending on your connection speed that really doesn't look so nice.

An appropriate solution would wait until the picture is loaded and then display it with a smooth fade-in. Maybe some JS magic?

Cole? Anybody?

Thanks and best regards
Photo of moschM

mosch

  • 9 Posts
  • 0 Likes
  • still tinkering with AF …

Posted 4 years ago

  • 1
Photo of Allan Cole

Allan Cole, Owner

  • 2047 Posts
  • 112 Likes
Hi, the image fade ins are set to happen after the entire page has loaded. However, the JS scripts are client side scripts so a slow internet connection or even a computer with a slow processor may not be able to handle the scripts or display the fades correctly.
Photo of moschM

mosch

  • 9 Posts
  • 0 Likes
No. Empty your cache and than look at your two demo sites:
http://fthrwght.com/autofocus/plusdemo/ go back to page 2 or 3 and see how the images 'load' from top to bottom.
http://fthrwght.com/autofocus/prodemo/ go back to page 2 or 3 and see that all pictures stay in the base color (red) and are 'faded in' once they are loaded.

A world of a difference. How to implement that functionality in the plus theme? Any new/changed/modified scripts?
Photo of stephanenglS

stephanengl

  • 4 Posts
  • 0 Likes
I have the same problem. While the image fade on the AF+ demo and other AF+ powered sites seems to work flawlessly, somehow it doesn't on my site. Interestingly the fade in works once the pictures are cached for the first time.

Allan, any idea? For a live demo of the issue have a look at: http://bit.ly/eBtfYJ