Mouse in game seems floaty and slightly delayed

  • Problem
  • Updated 1 year ago
  • In Progress
Reposted from forums by request of Justin, as it's a bug.
Original forum post; http://www.ftlgame.com/forum/viewtopi...

As soon as the starting loading screen finishes, there seems to be a slight delay to any mouse movements. It isn't a huge problem, due to the nature of pausing in-game, however, the gameplay would seem much smoother, and I don't remember having this problem for the onlive demo.

Justin said my PC specs shouldn't be a problem- dual core 2.2ghz, 4gb ram, intel Hd graphics, windows 7.

Other than that, great game!
Photo of Paul Hackett

Paul Hackett

  • 5 Posts
  • 3 Reply Likes
  • thinking it could be worse

Posted 3 years ago

  • 9
Photo of Matthew Davis

Matthew Davis, Programmer

  • 2225 Posts
  • 183 Reply Likes
Responding here and the forum for maximum coverage:

Please make sure your drivers are fully up to date, especially for integrated cards. We've had issues where the drivers supplied by Lenovo for the integrated cards were not the correct drivers and were causing extreme slowdown issues.

The floaty mouse is most likely caused by a slightly too slow framerate, but that should be fixable. If you're right on the edge of playability (so not running at 5 FPS), then turning of vertical sync might solve your problem. The game is automatically attempting to force it off, but some systems like to force it on. You should have some sort of graphics control panel, I'm not sure how it works for the Intel HD cards, that will allow you to switch Vertical Sync to be "Application Settings" or even just "Off." Give that a shot.

Sorry about the problems though. Hopefully we can get this fixed.
Photo of sebastienricher

sebastienricher

  • 14 Posts
  • 1 Reply Like
I get this on the Samsung Series 9. This is a big hit on quality, the game feels clunky. With this fixed, experience would be back to the awesomeness it should be.
Photo of Matthew Davis

Matthew Davis, Programmer

  • 2225 Posts
  • 183 Reply Likes
What are the specs on your machine? Since it's likely due to performance problems, the cause it going to be unique from system to system.
Photo of Matthew Davis

Matthew Davis, Programmer

  • 2225 Posts
  • 183 Reply Likes
And sorry about the problems :(
Photo of sebastienricher

sebastienricher

  • 14 Posts
  • 1 Reply Like
http://www.samsung.com/us/computer/la... Here are the specs, intel i7 with 8gigs of ram. Intel® HD Graphics 3000, which is not super performant. Machine is up to date (this is my dev machine). Thanks!
Photo of Matthew Davis

Matthew Davis, Programmer

  • 2225 Posts
  • 183 Reply Likes
Can you install fraps and see what kind of framerate you're getting? I have a very similar laptop with no problems.
Photo of sebastienricher

sebastienricher

  • 14 Posts
  • 1 Reply Like
Framerate is quite decent (very good actually), I'll try to take the time to get a video, but it runs smooth other than mouse.
Photo of ScottS

Scott

  • 2 Posts
  • 0 Reply Likes
I have the same issue on my PC. I did recently have an ATI graphics card that died so I stuck in an GeForce 8800 GT that I had lying around. I'm not sure if that's related, but I figured it's worth mentioning.

Here's my pastebin of my DxDiag.txt file http://pastebin.com/GLJA1VbB
Photo of Matthew Davis

Matthew Davis, Programmer

  • 2225 Posts
  • 183 Reply Likes
Hi Scott. If your dxdiag file is accurate with your drivers date, your video drivers are 3 years old. Give updating those a try to start with.

Sorry you're having problems :(
Photo of ScottS

Scott

  • 2 Posts
  • 0 Reply Likes
Updating the drivers did fix my issue btw. Forgot to mention it.
Photo of deman8899D

deman8899

  • 4 Posts
  • 0 Reply Likes
I have the same problem, I too am on Windows 8, which may contribute to the problem
Photo of deman8899D

deman8899

  • 4 Posts
  • 0 Reply Likes
I tested on another (lower-specced) computer, and the game worked great. And was insanely fun, I kind forget to test anything until I died to the flagship, but vsync was forced off. I'm guessing I'm gonna need to wait for better AMD windows 8 drivers, most games seems to work fine however.

dxdiag of Windows 8 Computer with laggy mouse: http://pastebin.com/AZy3Wq2K
Photo of Matthew Davis

Matthew Davis, Programmer

  • 2225 Posts
  • 183 Reply Likes
Forgot to say so below, but I do apologize for this inconvenience. I'm glad you are able to run the game and enjoy it on another machine though :)
Photo of Matthew Davis

Matthew Davis, Programmer

  • 2225 Posts
  • 183 Reply Likes
Yeah, it looks like AMD isn't officially supporting Windows 8 for anything prior to the HD 5000 line. Hopefully that will be remedied soon and probably explains some of the hit and miss experiences we've had with Windows 8.

EDIT: http://support.amd.com/us/kbarticles/...

Though that hasn't been updated in awhile, anyone else feel free to update us if I'm wrong on that front.
Photo of Paul Hackett

Paul Hackett

  • 5 Posts
  • 3 Reply Likes
Just to add an update for me- The driver is the latest available, so it isn't that. Not sure what else to try.
Photo of deman8899D

deman8899

  • 4 Posts
  • 0 Reply Likes
Matthew, AMD is not supporting legacy GPU's yet, IE my own HD 4000 series. I've tried 3 computers now, all work except the W8. With the Win 8 comp easily having best CPU, GPU, RAM, etc. Hopefully AMD will release better drivers by W8 official release.

AMD appears to not have plans to support legacy devices: http://www.techspot.com/news/48321-am...
Photo of deman8899D

deman8899

  • 4 Posts
  • 0 Reply Likes
Just want to say I have it working, I reverted the driver to Basic Windows VGA Adapater, then installed from a zip file of Windows 8 CP drivers, (non-installer), just a folder of drivers.
Photo of Gomisan

Gomisan

  • 183 Posts
  • 27 Reply Likes
Well long time beta tester and finally now the game is out I thought I'd test it out on a different (non steam connected) PC.

Unfortunately, the mouse is so slow and laggy that it's not really playable.

Graphics card is ATI Radeon HD 2400 XT, pretty basic as it's a work PC unfortunately.
PC is Win7 32Bit, 8gb RAM (only using 3.5), Intel Core 2 Duo E8400 @3ghz

I'll try a driver update and see what the difference is.
Photo of Gomisan

Gomisan

  • 183 Posts
  • 27 Reply Likes
Yup a driver update worked... but not the 12.8 drivers, the 12.6 ones.
Photo of Paul Hackett

Paul Hackett

  • 5 Posts
  • 3 Reply Likes
Sadly I can't backdate the drivers my PC is running- They're the ones it came with, and there hasn't been an update. ....Interesting, though.
Photo of Alex KowalczukAK

Alex Kowalczuk

  • 1 Post
  • 0 Reply Likes
Is there any chance we could get a "Use Raw Mouse Input" option added to FTL? That would fix this problem entirely. Unfortunately, I'm no programmer and have no idea how difficult this is to implement or how long it would take. I'm getting minimal lag despite an excellent framerate, but it's still definitely noticeable and pretty annoying. I'm curious about raw mouse input, some games have it to solve this problem I'd like to know if it's an option for FTL.

Thanks
Photo of Carl DaynesCD

Carl Daynes

  • 7 Posts
  • 0 Reply Likes
Fyi just got this fixed on my HP 6730b with Intel HD 4 graphics by downloading the manufacturers latest drivers for windows 7 (I'm running windows 8)

my nvidia machine was fixed by new nvidia drivers
my ati machine worked out of the box.

happy hunting
Photo of Art Patscheck

Art Patscheck

  • 4 Posts
  • 0 Reply Likes
Just bought the game tonight. Same thing, game is unplayable. I have an Alienware M17 with dual ATI Radon 3870's. I have the most up to date video drivers available from Alienware. I've tried every combination of settings I can think of including reinstalling my drivers. I turned performance all the way up in the Catalyst control center. Vsync is off there as well. All other games play fine. Any ideas?
Photo of Art Patscheck

Art Patscheck

  • 4 Posts
  • 0 Reply Likes
Vsync on and off. Add/remove programs to uninstall drivers. Alienware's drivers are like 3 years old anyway. I'll google how to turn off crossfire.
Photo of HypoceeH

Hypocee

  • 400 Posts
  • 22 Reply Likes
Ah. Yeah, three year old drivers aren't gonna work, and indeed those look to be the most recent offered by Alienware. I thought Alienware were a gaming machine comapny and might prioritize putting out updated drivers for their stuff :/ - and I had thought you must be on the M17x because they like model number shenanigans.

These threads fix a different issue with a different game, but are quite recent and look like a good guide to getting 12.x Catalyst installed on your system rather than 10.3. It wouldn't be custom-modded like the Alienware package, but AMD says most mobile features are integrated since the late 10s. Who knows, but I think a couple years of driver patches probably beats power profile tricks or whatever system integrators patch in.

http://us.battle.net/d3/en/forum/topi...
http://us.battle.net/d3/en/forum/topi...
Photo of Art Patscheck

Art Patscheck

  • 4 Posts
  • 0 Reply Likes
Ill check out those links, thanks! Yeah I'll never buy an Alienware again. You don't know about the customer service nightmare I had when I first got it.
Photo of Art Patscheck

Art Patscheck

  • 4 Posts
  • 0 Reply Likes
Oh. Em. Gee! The 12.6 drivers actually installed on this thing and the game runs perfectly! Thank you so much! :)
Photo of HypoceeH

Hypocee

  • 400 Posts
  • 22 Reply Likes
Eeeegzellent. Good luck with that desperate mission through the turmoil of civil war.
Photo of goldarynG

goldaryn

  • 8 Posts
  • 0 Reply Likes
I had this issue - sharing my FIX :)

I had the very laggy floaty mouse issue, even with the latest everything (including DirectX and ATI drivers).

The issue turned out to be **drumroll** an old Windows 7 image. I updated Windows 7 to SP1 and all the latest updates and now it runs flawlessly. I'm not sure whether it was the SP1 or one of the subsequent updates but after doing both, FTL ran perfectly on a vanilla install of Windows (I might have installed DirectX, I hadn't installed the ATI drivers. I have now.)

Updating Windows also fixed lag and jerkiness in a whole bunch of other new games including Terraria, Torchlight 2, and Borderlands 2 (yes I did enjoy the Steam xmas sale). Everything is smoother than ever, I can't believe that a Windows update actually affected my gaming (lol). Moral of the story - If you are a gamer, update Windows, even if you think (like I did) that it won't affect much.
Photo of LennierL

Lennier

  • 1 Post
  • 0 Reply Likes
Just wanted to add my experience with this issue in the hopes that this will be of some use. For me the mouse was so slow I it took ages just to click anything in the startup screen. After reading this thread, I tried *downgrading* my graphics driver and this completely solved the problem.

I have an old laptop: an Inspiron E1505 dual core 1.83GHz CPU, with a GeForce GO 7300, running Ubuntu 12.04. I had the NVIDIA proprietary driver version 304. Downgrading to version 173 did the trick. Happy to be able to play but eventually I'll want to re-install the newer driver for other games.

Anyway, hope this helps and thanks for making this amazing game!
Photo of Chaubin

Chaubin

  • 2 Posts
  • 0 Reply Likes
On windows 8 and I tried updating and downgrading my graphics on both my laptop and my desktop and I still have to click 3 - 4 times for anything to work when targetting with weapons. Tried full screen and windowed and all graphics options. Out of ideas and this *just* started happening a couple of weeks ago.
Photo of Dimitar Velichkov

Dimitar Velichkov

  • 3 Posts
  • 0 Reply Likes
Fullscreen works perfectly fine. Windowed, however, lags. Updated drivers, tried pretty much anything offered on forums and still nothing. I really don't want to alt-tab.
http://pastebin.com/eqi426n5