Help get this topic noticed by sharing it on Twitter, Facebook, or email.

I can't see the requirements to download GapMinder for my Mac, they tell me the link is broken

When I open the link to install GapMinder Desktop I am greeted with a message that says "Your system doesn't meet the requirements to run Gapminder World Offline.", however, when I click in the word "requirements" it re-derects me to a "Not Found" page, so now I don't know what are the requirements to download it.
1 person has
this question
+1
Reply