Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Not working on Scientific Linux 6.x

I downloaded Gapminder+Offline-linux.zip on my 64-bit Scientific Linux 6.x system and when I tried to run it I got the following error messages:

/usr/local/lib/Gapminder Offline-linux# ./Gapminder\ Offline
./Gapminder Offline: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./Gapminder Offline)
./Gapminder Offline: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by ./Gapminder Offline)
./Gapminder Offline: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.5' not found (required by ./Gapminder Offline)
./Gapminder Offline: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/local/lib/Gapminder Offline-linux/libnode.so)
./Gapminder Offline: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/local/lib/Gapminder Offline-linux/libnode.so)

I have the SL6 repositories' latest version of glibc.x86_64 -- namely, 2.12-1.209.el6_9.2 -- so now what?
1 person has
this question
+1
Reply
  • Thanks for letting us know! I'll make an issue for a linux team to investigate and be back to you when there is progress

    For now you can try other platforms or the online version here gapminder.org/tools/

    angie
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned

  • So back to this, sorry if my answer makes you sad, we decided that there are no actions we can (afford to) take at this stage regarding improvements of compatibility.

    The root cause of the problem is that the Electron framework, which G Offline app is based on, is missing dependencies on Scientific Linux, and there isn't much we can do about it. (See also https://github.com/electron/electron/...)

    What we can advice is to use a more popular distribution of Linux where the dependencies are resolved and Electron works. Or wait till either Electron or Linux would improve their compatibility.

    Do you mind we contact you to see if it works later when we have a new major version of G Offline with the updated Electron? Drop your email to me: angie@gapminder.org

    thanks! Angie from Gapminder
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned