Admins: How to put Get Satisfaction on your site

  • Announcement
  • Updated 4 years ago
Archived

This conversation was archived and is no longer visible to community members.

The "Put Get Satisfaction on Your Site" page of the Admin section is where admins can find our nifty widgets. Currently, we have two widgets:

1. Topic Search Widget: Allows your users to search and get results for Satisfaction topics on your own website. They'll also be able to submit new topics! Once they click on a listed topic suggestion or hit the "Add details and submit" button they'll be taken to the corresponding page in your Satisfaction site.

2. Live Topic Widget: Put a list of Get Satisfaction topics from your Satisfaction site on your own website. Choose what kind of topics, how many, and more. It's like a dynamic FAQ. Once a user clicks on one of the topics they'll be taken to that topic page on your Satisfaction site.

To add either of these widgets click the "Customize it!" link. Then you'll be able to customize the parameters for the type of results you want displayed and see a handy in-line preview by clicking the "Preview" button. Once you've set the options the way you want them, copy out the Markup code and CSS code by clicking the corresponding "copy" buttons and pasting in the appropriate places in your site. You can customize the visual look of the widget to match your site by changing the CSS or changing the markup to call your own CSS code.

We also have a couple of badges you can use as links from your web site to your Get Satisfaction site.

And for the more ambitious among you, we now offer Help Center -- an open source PHP based template based off our API which allows you to install a customizable version of Get Satisfaction on your own site.

Get Satisfaction - Get Satisfaction

Amy Muller, Co-founder

  • 460 Posts
  • 82 Likes
  • hoping this is helpful.

Posted 7 years ago

Designoclast

  • 0 Posts
  • 0 Likes
Totally helpful. Thanks so much for posting this! Now time to implement it.

Samuel Gib Johnson

  • 0 Posts
  • 0 Likes
help me so i can get started when u learn enuff

Amy Muller, Co-founder

  • 460 Posts
  • 82 Likes
You're welcome!

scotth

  • 0 Posts
  • 0 Likes
These features look very cool -- can't wait to try them out! I am experimenting with the search widget right now and just encountered a problem. When I click the "add details and submit" button, a new window opens with an HTTP 500 error. The URL says this:
http://getsatisfaction.com/tripit?top...

I was using IE 7.0 on Vista when that happened (I'm using Firefox to post this because I find that your site works much better on Firefox).

scotth

  • 0 Posts
  • 0 Likes
I just tried the same thing above using Firefox and this time I get to the satisfaction site (no HTTP 500 error) but I get a message saying there was an error on the site. I do see the original question I entered on the search widget showing up at the top of the satisfaction page, however, so I know at least that info is getting passed through.

Amy Muller, Co-founder

  • 460 Posts
  • 82 Likes
We're currently working on some bugs with the widgets right now. We'll look into your issues too. We may have more questions to help us reproduce them. Sorry about the buggyness today and thanks for helping us out!

scotth

  • 0 Posts
  • 0 Likes
No worries, I'm happy to help however I can -- I know how tricky it can be to debug. I can take screenshots, provide more detail, whatever you guys need -- just let me know.

Amy Muller, Co-founder

  • 460 Posts
  • 82 Likes
Ok, thanks much. As soon as one of our developers has a sec I'll see if they need more info from you.

Cameron Walters

  • 3 Posts
  • 0 Likes
Scott, we would love to have a look at screenshots of what you're seeing. Please send a few our way to me (cameron) and ted [at] getsatisfaction [dot] com. Thanks!

thibodeaux

  • 0 Posts
  • 0 Likes
OMG I must be blind or something... Where exactly do I get the code to integrate these widgets?? Maybe I'm not an "admin"?

I don't see the "Get it" button referred to in the original post.

Cameron Walters

  • 3 Posts
  • 0 Likes
Sorry, thibodeaux, you are right! You were not marked as an admin for The Method Agency. I've done that for you. You should now see a new link in the upper right near your name that will take you to the section of Satisfaction referred to in the original post.

Wytze

  • 2 Posts
  • 2 Likes
I seem to share Thibodeaux's problems. I am admin for my company 'Stichting OPC' but I see no 'Put Get Satisfaction on your site' page.

yoursports

  • 0 Posts
  • 0 Likes
My widget does not show responses for questions posed, except for Satisfaction responses - example here http://yoursports.com/info.php?page=faq

Any thoughts?

Cameron Walters

  • 3 Posts
  • 0 Likes
Perhaps you are confused. The widget is not showing any responses (I believe we are planning a widget that will show the latest response, or the top/promoted responses).

What you are seeing is the additional detail on the original topic:
yoursports // webTV
Uploaded with Skitch!

Amy Muller, Co-founder

  • 460 Posts
  • 82 Likes
If you add more topics and include text in the "Add details" text box then you'll see some portion of those details displaying as well. You can also choose to have no extra details display by selecting "no summary" under the Summary length option when setting up your widget.

stevel

  • 0 Posts
  • 0 Likes
I've tried to embed a really simple Live Topic widget that just shows all the topics for Songbird. But even the preview on the satisfaction site doesn't seem to work. It doesn't show anything besides "Loading..."

When I paste it into my site, and try to load - I see Javascript errors on the Error Console saying:

Error: gsfnTopicsCallback is not defined
Source File: http://getsatisfaction.com/songbird/t...
Line: 1

You can see how I've tried to load it in here:
http://www.songbirdnest.com/node/2260

Cameron Walters

  • 3 Posts
  • 0 Likes
Uh oh, that doesn't sound right at all. We'll take a look at it right away. Could you give us a little more background (what browser you are using, etc.)? Thank you for letting us know!

stevel

  • 0 Posts
  • 0 Likes
Sure thing...

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

Scott Fleckenstein, Champion

  • 22 Posts
  • 8 Likes
Seems to me that the widgets.js base javascript file isn't loading for you.

Are you sure that you included the javascript link to http://1.static.getsatisfaction.com/s... when you embedded the widget in your site?

Also, you can try just loading that in the browser, perhaps it is erroring out on the server when you are trying to request it.

stevel

  • 0 Posts
  • 0 Likes
Yup - definitely got it on there. You can see for yourself at the test page @ songbirdnest.com.

It loads okay in a separate browser window.. even if it were a user error in my copy/paste, shouldn't the Preview section/box on the Admin page in getsatisfaction.com's site still work? That shows the same symptoms...

Scott Fleckenstein, Champion

  • 22 Posts
  • 8 Likes
stevel,

The test page you pasted just responds with an Access Denied error. I cannot see how you have embedded the widget on your site.

As far as it not working in the preview box, could you check it again? One of our servers wasn't playing nice around the time you posted this, but it is up and running again.

The preview page is working fine on the systems I am testing it from, so if it is still breaking for you that means that there is something specific between your browser and the server that is causing the issue.

If you can give me access to your page that has it embedded, we should be able to track this down quickly.

stevel

  • 0 Posts
  • 0 Likes
Hey Scott - yup that was it. Both my test page and the live preview are working successfully now. Thanks for getting it fixed so quickly!

Scott Fleckenstein, Champion

  • 22 Posts
  • 8 Likes
Glad to hear it is working now. I was a little afraid that the problem you were having was something more complicated, so I'm glad it turned out to be something simple.

Darla

  • 0 Posts
  • 0 Likes
i can't see the get it button either.

Eric Suesz, Champion

  • 108 Posts
  • 27 Likes
Darla, you have to be an admin to see that button. I see your admin claim now, and I am approving your claim. So, try it again and let me know if you have any problems or want any help!

Timothy Leung

  • 0 Posts
  • 0 Likes
Has anyone gotten it to work with ASP.net?

The topic widget doesn't seem to fire off maybe because it is nested within a form tag?

Scott Fleckenstein, Champion

  • 22 Posts
  • 8 Likes
If you've got the widget nested within a form element of your own, I don't think the widget will be able to work for you.

The most obvious solution is to not wrap your entire page in a form element, but barring that as a possibility, I would recommend that you instead replicate the widget functionality using the API.

I would be happy to describe the resources you would pull from if that is your desire.

-Scott