Can not login by SSL.

  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Community cleanup. Topic has not had much activity or pageviews. If you still have this question please repost in the community! :)

We used the fastpass integration with GetSatisfaction on login page. Our portal used https and get the security warning because of the link to GetSatisfaction is http. I've read the article (http://getsatisfaction.com/developers...) but it isn't working for my because I used java for generating the URL and put it as javascript tag to the page.
Unfortunately nothing happened. If I put generated link into browser directly I get the security warnig with confirm button. So, the question, how I can implement the SSO integration for SSL site in silence mode? Without any warnings and pop-ups.
Photo of Ivan Drizhiruk

Ivan Drizhiruk

  • 100 Points 100_badge_2x_thumb

Posted 3 years ago

  • 1
Photo of Amy Cottrell

Amy Cottrell, Alumni

  • 16,882 Points 10k_badge_2x_thumb
Hi Ivan,

I apologize for any frustration this has caused. I'm going to share this question with our tech team right now and someone will follow up shortly to help you out. Thank you for your patience!

Amy :)
Photo of Adam

Adam, Champion

  • 18,422 Points 10k_badge_2x_thumb
Hey Ivan.

Thanks for reaching out to us in the community about this. Can you let us know which community this regarding? Thanks so much.

Adam
Photo of Ivan Drizhiruk

Ivan Drizhiruk

  • 100 Points 100_badge_2x_thumb
Photo of Jenn Lin

Jenn Lin, Alumni

  • 20,476 Points 20k_badge_2x_thumb
Hello Ivan,

Thanks for the problem report. It might work best to talk about this on a phone call.

I suspect that since you are calling FastPass from HTTPS, if you try to call the FastPass code with is_secure=true, then there will be a permanent redirect to the site, which is at HTTP://community.htkhorizon.com/. This will cause a 301 or 302 error on the FastPass page and it will possibly write the cookie to the invalid HTTPS domain.

At the enterprise level, there is an option to add HTTPS to a community with a CNAME, such as yours.

I believe your options on the Connect plan are:
- Remove the CNAME so the page is fully HTTPS
or
- Call the FastPass code from an HTTP page

Could those options work? Again, email me at jenn at getsatisfaction dot com to coordinate a call later in the week to talk it through together.

Thanks!
Jenn

This conversation is no longer open for comments or replies.