will not install in safari 5.1.2..

I tried installing Ghostery today on Safari 5.1.2. It keeps telling me.. "An error occurred while installing the extension “Ghostery”." What am I doing wrong?
1 person has
this problem
+1
Reply