cannot make calculations in CSV amount field

  • 1
  • Question
  • Updated 5 months ago
New user from Italy. Everything seems working quite fine up to now. However, using MS Office with Italian localisation, I cannot make any kind of calculation in the amount column when exporting to Excel. I've tried several fixes (eg: changing column format either on the final Excel file or changing querying format before exporting from .csv to .xlsx) ) but either I get a wrong number format allowing me to make calculations (e.g.: instead of € 52,50 I get € 5.250) or I still get a textual format which is formally correct but is not recognized as a number (formulas don't apply and  pivot tables  also do not work). I tried to find a solution within your very large user forum but I did not succeed in finding something helpful. Could you please tell me  the right solution to overcome my problem? Thank you and kind regards.
Photo of Roberto Nardi

Roberto Nardi

  • 1 Post
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Wayne Woodbury

Wayne Woodbury

  • 224 Posts
  • 172 Reply Likes
Tchau, Roberto.  Welcome to Goodbudget.  It looks to me like your facing a localization issue with the ',' and '.' characters.  I had troubles locating any settings for localization, but perhaps one of the Goodbudget people can provide more detail on that.

In the mean time, try reversing your ',' (comma) and '.' (period) characters in your euro amounts such that the comma is used as the thousands separator and the period is used as the division between whole euro values and cents.  Several European countries like Italy and Belgium use the period as a thousands separator and the comma as the whole value separator (not sure what this is called in Italian, but it is the "decimal place" in English and "virgula" in Portuguese).  Therefore 5,250 will be five thousand two hundred fifty euros instead of 5 euros and 25 cents and 52.50 will be interpreted as 52 euros and 50 cents.

Here are two links to articles in the the Help section that might help (read the second one first):
https://help.goodbudget.com/customer/en/portal/articles/1583297-how-to-import-csv-files
https://help.goodbudget.com/customer/en/portal/articles/2849910-i-can-t-import-my-csv-file-what-do-i-do-
Photo of Alex Park

Alex Park, Official Rep

  • 240 Posts
  • 48 Reply Likes
Hi Roberto,

It sounds like you're exporting your transactions from Goodbudget as a CSV file, and are having difficulties using any formulas on that data when you bring the CSV data into Microsoft Excel.

As Wayne also notes above, I suspect this may be an issue caused by how Microsoft Excel is reading the CSV file you've exported from Goodbudget. Coincidentally, I was looking into the Goodbudget CSV export files the other day, and it seems that Excel can sometimes experience problems interpreting how Goodbudget has saved certain characters, particularly if you open the CSV directly into Excel. If you instead import that CSV file into Excel with a specific group of settings, it seems you can prompt Excel to read the Goodbudget CSV's data more accurately. I've done a write-up on how that might be specifically done (link here), would you mind following those instructions and seeing if that helps you with your problem?

If not, would you send us an email at support@goodbudget.com with your Goodbudget household email address, as well as the CSV file you're trying to use, so we can try looking into this issue further?