Getting rid of notification asking to save location

  • 1
  • Problem
  • Updated 10 months ago
On my android app, roughly 75% of the time when I save a transaction I get a notification in the app that prevents me from saving my entry telling me to go into my settings and turn on location for quicker entry suggestions.

Most of the time I put my transactions in GoodBudget at home or nowhere near the store so this feature is useless to me, and no matter how many times I tell this notification "no" it keeps asking. I'm annoyed that I have to keep dismissing this. Is there a way to disable this notification??
Photo of Tim

Tim

  • 3 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Becky Huang

Becky Huang, Official Rep

  • 1560 Posts
  • 78 Reply Likes
Hi Tim,

Sorry about that! Try going to the Goodbudget app Settings screen (you can find it by tapping on the three vertical dots at the top right of your screen) and deselecting the "Use Current Location" check box. This should remove the "Save location to transaction" option on the Add Transaction screen that triggers the notification you're describing. 

Let me know if that doesn't work for you,
Becky
Photo of Tim

Tim

  • 3 Posts
  • 0 Reply Likes
It has been deselected. I even selected it and deselected it again to try to fix the problem but to no avail.
Photo of Becky Huang

Becky Huang, Official Rep

  • 1560 Posts
  • 78 Reply Likes
Hi Tim,

When you deselect the "Use Current Location" in settings, does it remove the "Save location transaction" option at the bottom of the Add Transaction screen? 

Try this:
  • Go to your phone Settings > Apps > App Manager > Goodbudget > Permissions > Disable location
  • Go to Goodbudget Settings > select "Use Current Location" and you should get the notification that says "Allow Goodbudget to access this device's location?" Select the "Don't ask again" radio button and "Deny."
If that doesn't work, can you send a screenshot of the notification you're seeing and of your Phone Settings and Goodbudget Settings? You can send them directly to support@goodbudget.com.
Photo of Tim

Tim

  • 3 Posts
  • 0 Reply Likes
Awesome service you're offering. I did these steps and will use it for a few days and see if its fixed. Thank you!
Photo of Cody Moore

Cody Moore

  • 1 Post
  • 0 Reply Likes
I am having the same issue (although with an iPhone). I also update all the transactions from home so the location has nothing to do with where the money was actually spent. I have the location settings set to "Never" for this app and yet it always has the default "Save location to transaction" turned on. How can this setting be changed to off please?  
Photo of Alex Park

Alex Park, Official Rep

  • 270 Posts
  • 57 Reply Likes
Hi Cody,

Unfortunately at this time, the "Save location to transaction" toggle will always be set to on regardless of your other settings. That being said, I can assure you that if you have your location settings set to "Never", Goodbudget will not actually save your location data, regardless of what the toggle might try to tell you.

Hope that helps.