I cannot add comma sign when I try to add transaction.

  • 4
  • Problem
  • Updated 6 months ago
  • Acknowledged
On Iphone application I cannot add comma sign. Probably because I’m from Poland and we use comma against dot sign to split full PLN against subPLN. When I’m trying to add a transaction on my numeric keyboard there is a dot but it is gray and doesn’t work.
Photo of Przemyslaw Łagód

Przemyslaw Łagód

  • 5 Posts
  • 1 Reply Like

Posted 10 months ago

  • 4
Photo of Margriet Marree

Margriet Marree

  • 2 Posts
  • 0 Reply Likes
Same here in the Netherlands! Problems on Iphone after updating IOS
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi Margriet,

Sorry for the troubles and thanks for your comment! Would you mind sharing what Language and Region setting you are using on your phone?
Photo of Margriet Marree

Margriet Marree

  • 2 Posts
  • 0 Reply Likes
Both Dutch/Nederlands
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Thanks for confirming your details, and thanks for your patience -- I've added your case to our bug tracker. In the meantime you should be able to use the Web version of Goodbudget to enter values containing decimal amounts.
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi Przemyslaw,

Sorry for the troubles! We've recently become aware of this bug and, as you say, it seems to be affecting those using specific iPhone Language and Region settings when they try to input decimal values using commas on iOS 12. We have confirmed that this bug affects those using whose Language setting is Polish and a Region setting is Poland, would you confirm that these are the settings you are using?

I've added a note to our bug tracker. But in the meantime, you should be able to use the Web version of Goodbudget (https://goodbudget.com/home, or More > Manage Household on the Web from the iPhone app) to add amounts containing decimal values.

Photo of Przemyslaw Łagód

Przemyslaw Łagód

  • 5 Posts
  • 1 Reply Like
Hi Alex,
Yes it is Polish settings (language and region). Now I'm puting a transactions without subpart of Polish Zloty and going back to transaction list, using edit transaction I have an amount with decimal part as for example 12,00 so I deleting 00 and filled with my subpart. It takes lot of time thats why I decide to wrote about it.
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi Przemyslaw,

Thanks for your follow-up, and thanks for your patience. I've confirmed your details in our bug tracker.
Photo of Przemyslaw Łagód

Przemyslaw Łagód

  • 5 Posts
  • 1 Reply Like
Thanks. How do You think it takes time to solve it ?
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
I'm afraid I can't offer a time estimate, but I can tell you that we've reported the issue to Apple and they've said they're looking into it. Thanks for your patience!
Photo of Robert

Robert

  • 1 Post
  • 0 Reply Likes
I have the same problem here in Austria and look forward to a bug fix ...
Photo of Przemyslaw Łagód

Przemyslaw Łagód

  • 5 Posts
  • 1 Reply Like
Maybe Goodbudget team can add 0,00 in this table by default ? This will help a lot :-) I don’t think so you need a Apple to do this :-)
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Thanks for your suggestion! We'll keep you updated if there is progress on this issue!
Photo of Viktorija Ustinovica

Viktorija Ustinovica

  • 1 Post
  • 0 Reply Likes
Hello, I use application for couple years, but since the last month I can't use coma or dot. At the same time my husband has no problems. Probably I have the same problem. I am from Latvia.

(Edited)
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi Viktorija,

Sorry to hear about the troubles adding decimal values. We'll post an update if the issue gets fixed, but in the meantime as a workaround you should be able to add transactions as normal from the Web version of Goodbudget, or by adding transactions in mobile without the decimal values, and then editing in the decimal values afterward.
Photo of Malene Nielsen

Malene Nielsen

  • 1 Post
  • 1 Reply Like
Same problem here. Using Dutch settings in the Betherlands. Hoping for a quick fix. Really annoying!
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi everyone,

Thanks for your reports, and sorry again for the troubles adding decimal values through the Goodbudget iOS app. We've confirmed that there is currently a bug affecting people who are on iOS 12 and are using iPhone Language and Region settings where the comma is the default decimal separator. In this bug, the Goodbudget app will correctly show commas (,) as the decimal separator, but the numberpad that is used to enter amounts shows a period (.), preventing entry of decimal values.

We've reported the issue to Apple, they've let us know that it's on their tracker, and we will provide an update if there is a fix available. But in the meantime you should be able to use the Web version of Goodbudget (https://goodbudget.com/home, or More > Manage Household on the Web from the iPhone app) to add amounts containing decimal values.

If you are using an iPhone on iOS 12 and are instead seeing the opposite of the bug described, where the Goodbudget app shows periods (.) as the decimal separator and your numberpad shows a comma (,), this is a separate issue and can be alleviated by going to your iPhone keyboard settings (Settings app > General > Keyboard > Keyboards) and adding the "English (United States)" keyboard.

Sorry again for the troubles, and thanks for your patience.
Photo of Przemysław Łagód

Przemysław Łagód

  • 1 Post
  • 0 Reply Likes
I think that if such amount of people have the same issue, it cannot be an Apple issue but how you tract a pole that have to be filled. Even if this doesn't work, it's better to propose (in settings) to change keyboard from simple numerical to full, than propose to use web version. Please simple add possibility to change default keyboard from this simple numerical to alphanumerical.
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi Przemysław,

Thanks for your sharing your suggestion. We'll let you know if a fix is available.
Photo of Przemyslaw Łagód

Przemyslaw Łagód

  • 5 Posts
  • 1 Reply Like
Hello Alex,
Any progress ? Still problem is not solved. Maybe as temporary solution You can add 00.00 by default. It means if some try to add a value, the place is prefilled with 0.00 ? It help a lot because we can use a finger, delete 00 after decimal point and put rest of the value.
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi Przemysław,

Thanks for bringing this up again. No progress yet, but we've reported this issue to Apple and will be sure to let you know if a fix is available.
Photo of Leonardo Bighi Lourenço

Leonardo Bighi Lourenço

  • 1 Post
  • 0 Reply Likes
Still no fix? You have to stop pretending it's an Apple bug, because it doesn't any affect any other budgeting apps.  It's on your implementation of how you invoke the keyboard. And it's an easy fix, actually. I'm an iOS app developer.
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Hi Leonardo,

Sorry for the late response. We first noticed this issue when the new iOS 12 was released, and reported the issue to Apple at that time. They've since let us know that they're aware of the issue, that we're not the only ones to report the issue, and that they're working on fixing it for a future release.

We're sorry for the continued troubles, and we'll be sure to post an update if they release an update and we confirm that the issue is fixed.
Photo of Rita Dessai

Rita Dessai

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Decimals.

Hi,
Since I moved to iOS12 I’m not able to key in values with decimals.
Decimal sign in Europe is a comma and the keyboard has a dot.
After tapping it, I’m not allowed to key in more digits.
Any solution for this issue?
Photo of Alex Park

Alex Park, Official Rep

  • 243 Posts
  • 48 Reply Likes
Official Response
Hi everyone,

Apple has just released an update for iPhone, iOS 12.2, and that release seems to have resolved the earlier issues that prevented people using iPhone Language and Region settings where the comma is the default decimal separator from adding decimal values into the Goodbudget iPhone app.

If you were experiencing this issue before, if you update your phone's OS to 12.2, you should now find that the comma correctly appears as the decimal separator on the keyboard that shows when you tap to add an amount, and you should be able to add decimal values again without any problems.

Thanks for your patience, and please let us know if you have any further questions.
(Edited)