Why do my Youtube videos take an eternity to load?

  • Question
  • Updated 2 years ago
Why do my Youtube videos take a long time to load (3-4 minutes) when the videos on a computer sharing the same connection and using the same browser load instantly?
It doesn't matter if I use Firefox or IE the video still takes an eternity to load. I have a Gateway laptop with 1gb ram 1.6Ghz processor running windows xp sp3.
Photo of

  • 1 Post
  • 0 Likes
  • frustrated

Posted 6 years ago

  • 4
Photo of Phil Harnish

Phil Harnish, Employee

  • 26 Posts
  • 6 Likes
How quickly do videos load on other websites? Try http://www.vimeo.com , http://www.viddler.com and http://blip.tv for example.
Photo of jonkamm

jonkamm

  • 1 Post
  • 0 Likes
It happens on youtube.com, Vimeo.com, and any site with Flash video embedded. It takes a long time because it downloads the full video before it starts playing. So I'm thinking it is a progressive video download setting. I looked through all my flash 10 settings and I don't see anything. I have removed and reinstalled Flash 10.1 no luck. This is on a Windows 7 x64, with IE8, firefox 3.6 and chrome. It is definitely a flash issue as near as I can tell... oh joy. My Mac plays fine on the same network, so does a XP VMware machine. I'm stumped.
Photo of Jay AlterJA

Jay Alter

  • 2 Posts
  • 0 Likes
I've JUST started having the same issue brother. Out of the blue it just started happening. 3 - 4 minutes before any videos will load in the flash player. I've not changed any settings or installed any new recent software as of late. The only thing I've done with computer is reboot within the last 24 hours. Other then that it's exactly the same as before the reboot when flash video worked fine and has for years.
Photo of Jay AlterJA

Jay Alter

  • 2 Posts
  • 0 Likes
I should add that this is happening in Chrome and Firefox. I've not bothered to test IE since I can't stand even seeing it load on my desktop!
Photo of Hank Lundgren

Hank Lundgren

  • 1 Post
  • 0 Likes
same here. YT especially but it even took my browser 3-4mins to load the flash on Pandora! not the songs just the interface!!

FF/IE same deal. chrome no longer works @ ALL on my LT. I get the "oh snap" on any and all pages. Flock does not work; same total fail as Chrome.

I think win7 has totally HOSED me over on this one.

and no, it's not a cookies, registry, cache, spyware issues. and oddly enough there were no recent updates or changes to my LT that would be indicative of a problem....save a recent flash update (to the best of my recollection)
Photo of Rosà MariaRM

Rosà Maria

  • 1 Post
  • 0 Likes
3-4 MINUTES?!?!?!?!? my videos take 2 HOURS and they're only 4 minutes long!!!!! STOP COMPLAINING