Why is Hulu slow and choppy in full screen?

  • Problem
  • Updated 3 years ago
  • Solved
Hulu is slow and choppy in full screen. It used to work fine on my computer, and with some research I've come to believe that the problem is with the flash player (Adobe 10). Some have recommended that I go back to an earlier version of flash player (8 used to work, fine!) but hulu requires the latest version! I am convinced that this is not a 'capability' problem in any way with my hardware or connection for various reasons including the fact that flash players on other sites work fine in full screen and at even higher resolution than hulu's. Anyone have the same problem?
Photo of Rob

Rob

  • 5 Posts
  • 0 Likes
  • frustrated!

Posted 6 years ago

  • 161
Photo of

  • 16 Posts
  • 1 Like
Hi, I'm still going to upgrade my video card since my computer is abt 7/8 yrs old, but i found that the vids run seamless for me in full screen at lower resolution 800x600/650 (forgot the second #) but what tech supports never told me @ Dell was that screen resolution makes a difference with full screen (they just told me to upgrade vid card and add more memory). the vid is a little fuzzier but @ 800 resolution, i can select hi-res w/o the pic being choppy (well it chopped for a sec while it was adjusting). i thought i needed a special vid card to support it. Surprise Surprise. ***** U might not necessarily have to play vids on 800, u might just have to lower it to the next resolution below the one your @ currently. It's completely seamless full screen on 800X on my comp(i have a 22" flat screen Dell monitor) but do a trial and error on ur screen resolutions. I'd like to know how it turns out. I love Hulu, it helps me save space on my DVR by having to splitting viewing time btwn computer and tv ~owner of a Dell 4500
Photo of Rob

Rob

  • 5 Posts
  • 0 Likes
Thanks for the reply, but I already tried this. Even at extremely low resolution, Hulu still plays choppy at full screen. As I said, I do not think that this problem has anything to do with my computer's capability, but rather it seems to be a problem with Hulu's compatibility, or the new flash player version. As I said, Hulu used to work fine with flash 8. Flash 10 just seems to be weird.
Photo of sdtbftone1

sdtbftone1

  • 1 Post
  • 0 Likes
I have recently upgraded to windows 7 on my laptop-but tthe choppy video in hule has been occuring about 4-5 months now and I just doubled my memory? whats changed w/hulu--used to run fine???
Photo of joppadoniJ

joppadoni

  • 1 Post
  • 0 Likes
spot on, turning down from 2600 1800 to 1600 1200 weill help a lot or a comparative rez. good spot!
Photo of giffboakeG

giffboake

  • 1 Post
  • 0 Likes
Downloaded shockwave play and now all my videos play fine in full screen again!!! Sickkkkkkkkkkkkkkknesss
Photo of

  • 16 Posts
  • 1 Like
I have Flash 10 :-/ with the resolution change solving most of it ( i still have to add memory) but if anything email Hulu tho they will tell u to check ur bandwidth. And when in doubt, reinstall flash 10. Adobe might have a upgrade or tweak.
Photo of

  • 16 Posts
  • 1 Like
I upgraded to the latest flash player 10.0.22.87 which must be the version u were talking about. the previous one is still considered Flash player 10, but it was something like 10.0.11.... on filehippo.com you can downgrade to 10.0.11. I have no clue why there needed to be a upgrade. adobe flash player should have specs on the upgraded version and what it's "fixing" but if it isnt anything serious, just downgrade to the prev. version. thats what im doing. but i still need to buy extra memory from dell to get faster startup time and processing.
Photo of

  • 1 Post
  • 0 Likes
i've had exactly the same problem, and it's been driving me insane. full-screen video outside of the browser plays lovely, and youtube plays lovely full-screen in-browser, but hulu, gamevideos and some others are unbearable in full-screen mode.

i tried a thousand and three things, and finally found an answer that worked for me.

these guys - http://www.videolan.org/vlc/ - make a pretty great multi-type media player. i swear i'm no advertiser, but it works really well. i installed this program, making sure to check the boxes to install to my browser's plug-in (firefox in this case) and restarted the browser.

went into my browser's settings to be sure the vlc plug-in was selected for video types (and for active-x controls) and bumped over to hulu. full-screen played nice and smoothly.

so, that worked for me. maybe it's an answer for somebody here.
i'm not saying we should stop shaking our fists at adobe for being proprietary butt-heads, but maybe we need to shake 'em at apple here and there too. the quicktime plug-in was definitely my problem.
Photo of

  • 2 Posts
  • 0 Likes
how exactly do you set up vlc to handle the video? I'm not seeing an option for it anywhere in my firefox menus
Photo of

  • 16 Posts
  • 1 Like
Hey mikebchicago, it's during the installation. If u already have it installed u would have to reinstall it (but delete it from Add/Remove pgms in control panel) There will be a point where there's a checklist of what's going to be assigned. Just make sure Mozilla ActiveX and Firefox plugin are checked off. then restart firefox....well better yet, after the installation (or reinstallation) restart the computer. Good luck :-)
Photo of

  • 2 Posts
  • 0 Likes
Yea, I've got the plugins installed, however, where do I enable firefox to use the vlc plug in to run flash video? This is where I'm running into the problem, even with the plugins installed, I do not see an option to have flash open with anything other than flash
Photo of

  • 16 Posts
  • 1 Like
Hey mikebchicago, sorry for the months delay but I hope the other comments helped or an upgrade or smth else helped. When u install Vlc player and check the box for the mozilla active x and firefox plugin, that's all u would have to do. But it seems the prob might be beyong VLC's help if u are still having problems. The weird thing is my laptop isn't choppy at all for hours. I know it must be that I have hardly anything installed in it (i use my desktop mostly) so I am going to add more memory to what I already added. The computer is going to my brothers as soon as i can afford a new one (from way before this issue came up) for school. ***So pt is, if there is still a prob, it might be memory***
Photo of

  • 16 Posts
  • 1 Like
I will check that out Mr. Lewis, thnx. my brother's have that on their computer. that might be why their full screen vids are good (we have the same age computers). i'll try it out and let u know.

***but just 4 future reference, if u have a Dell, buying extra memory isn't expensive as i thought (could be happier if there wasn't 15$ tax) but for my Dell xp comp 512MB is $30. My neighborhood computer supply store says memory in general isn't expensive to buy.
Photo of

  • 16 Posts
  • 1 Like
It seems that VLC is working. I'm going to check it during the week. I still need to add more memory for my computer to move smoother overall, but this solves my video issues overall i think on websites in gnrl. Thanks Lewis! :-)
Photo of

  • 16 Posts
  • 1 Like
No, mike there is no need to "enable". If u see "VLC Multimedia Plugin" (after Shockwave Player, if u have that installed) in your Add-on list, you're good to go. U can disable any of ur addons simply by clicking "disable" that when u highlight the add-on. Did u try seeing a vid on hulu.com in full screen mode? if it's smooth, problem solved.
Photo of

  • 2 Posts
  • 1 Like
I have identified this problem on three different computers. A laptop with a mobile Athlon X2 2.0 GHz and GeForce 8200 video, a different laptop with an Intel Core 2 T-series 2.0 GHz and Intel GMX3100 video, and a desktop with an Intel Q6600 @ 3.4 GHz and a GeForce 8800 GT graphics. All exhibit the same symptoms of video being extremely sluggish when in full-screen mode.

In the cases of the Athlon X2 and Q6600 machines I was able to "solve" the problem by disabling hardware acceleration by right-clicking on the movie while the movie is playing, and unchecking the hardware acceleration option on the Flash menu. However, the Core 2 notebook did not work -- but I did notice that when I simply brought up the Flash menu, the movie would play smoothly in full-screen!!!!

This seems to be like a Flash problem at the very least, although it could be related to how Hulu renders the full-screen component. I hope this helps.
Photo of Loud.n.Clean

Loud.n.Clean

  • 2 Posts
  • 0 Likes
Josh your simple solution worked for me too thanks so much I have a Toshiba Satellite with a ATI Radeon 3100 graphics card with 4 Gigs of RAM. Anyone with this problem should try this fix first before installing anything. Thanx Josh!
Photo of shakrahnS

shakrahn

  • 2 Posts
  • 0 Likes
Thanks, solved the problem I was having on my laptop. Didn't even think to right click the video and change the flash settings themselves.
Photo of shakrahnS

shakrahn

  • 2 Posts
  • 0 Likes
Thanks, solved the problem I was having on my laptop. Didn't even think to right click the video and change the flash settings themselves.
Photo of prasanthjames

prasanthjames

  • 2 Posts
  • 0 Likes
Thanks Josh. That solved my problem
Photo of prasanthjames

prasanthjames

  • 2 Posts
  • 0 Likes
Thanks Josh. That solved my problem
Photo of

  • 3 Posts
  • 0 Likes
Perhaps you should add more RAM to your computer?

What KIND of processor are you running?
Photo of

  • 16 Posts
  • 1 Like
Just so u know about the recommended hardware Adobe states on the website for optimal performance:

http://www.adobe.com/products/flashpl...
Photo of

  • 2 Posts
  • 0 Likes
I'm having the same problem, and even with the add-on of VLC, Hulu still is choppy and stutters in full screen mode. Do I have to disable adobe shockwave, and if so how do I get hulu to recognize VLC? Youtube and all other flash based video websites run fine, video is smooth for all other sites but hulu. I have tried disabling hardware acceleration and enabling it. I cannot find a solution. Tahirah, how did you get VLC to run hulu smooth for you?
Photo of

  • 16 Posts
  • 1 Like
Hey Sid,

Well i have to keep my screen resolution on 1024X768 and there's a update for the VLC media player: 0.9.9 (use to be 0.9.8) u can get it off of filehippo.com You do need Shockwave Flash player to even see any of the sliding stills and vids on Hulu. VLC's plugin just helps with the smooth stream. I do agree with Hulu tech support that your bandwidth still affects the stream. I disabled my Divx web player plugin (which i only use on Ovguide.com or other sites that i def know have divx vids)

***when u install the vlc media player make sure that Mozilla is checked (Mozilla is firefox browser's maker) the VLC plugin only works with Firefox. I use to have IE 8 beta but when it clashed with older webpgs i downgraded to IE7 until the full IE 8 just came out. IE 8 seems to be working well as long as i keep my resolution on 1024

Regardless of the vids streaming smoothly now it still sucks cuz my 22" monitor is capable of 1680x1050 pixels and due to my low hard drive space (check ur disk space also, pgms dont run smoothly when u dont have enough disk space) i have to keep tabs of how many pgms i have installed. I am planning on adding more mem to my 2001 Dell for 30 bucks before i pass it on to my little brother and upgrade to a Dell Hybrid.

***SUMMARY: Upgrade to VLC 0.9.9 (make sure Mozilla box is checked so Firefox plugin gets installed!!!), try 1024x768 resolution, make sure u have enough disk space (firefox has been freezing on me & get "low virtual memory" notice every 10-15 mins), i think 40% and above disk space is best ( i only have 35% now), and any unneccessary plugins disabled from firefox.

(if u have Xp, delete stuff from prefetch folder---RUN>type "prefetch", delete temp internet files) RESTART BROWSER AFTER INSTALLATION
Photo of

  • 2 Posts
  • 0 Likes
Thanks for the info, it seems to be slightly better depending on what I watch. It still seems choppy, especially with movies. Animated shows are okay, but movies seem to be running at a low frame rate or something. I have never tried it in IE since I only use firefox. I guess I'm not destined to watch Hulu. Honestly though, they do need to improve their set-up. Thanks for the help, I've gotten about 20% better video. That'll have to do.
Photo of

  • 16 Posts
  • 1 Like
Yea, im having smth similar. But confidentially, on my sister's Mac it is not choppy @ all. I apt sat for her for a day, and was spending the whole time on Hulu! im not saying dump Windows system, but there could be a thing with the computer 2. i haven't asked someone with the latest Windows comp with loads of memory 2 try out Hulu. *sigh* Well 20% is better than 0 :-/ *** im getting a new laptop within a couple of weeks, just need 2 pick it up fm Jersey. I'll try out Hulu on that one--Latitude D610 and my cousin hasn't fully tested out her new Dell Studio laptop, i'll see if hers makes any streaming difference k?
Photo of

  • 2 Posts
  • 0 Likes
I've noticed the same puzzling problem with my girlfriend's computer using IE 7, XP and the newest version of Adobe Flash (10.0.22.87). I've spent the last few days looking for other people with this problem. A few months ago I used her machine to watch Hulu videos and didn't notice any stuttering. Now things are different.

I'm puzzled because I use Firefox on my own machine and just happen to have VLC installed as well. I have no problems with Hulu video on this machine. I believe the poor performance we're all seeing has little to do with hardware but more to do with Hulu/Adobe Flash. I'm also using the same Adobe Flash version on my machine.

My gf's machine is running current hardware that is similar to my machine (Intel C2D CPU, 2 gb of ram). I've upgraded the drivers for every component of her machine, uninstalled and reinstalled the Adobe Flash plug-in and let the video buffer to rule out the network bandwidth question. Normal size or full screen doesn't seem to matter; the dropped frames are noticeable in either setting. I have tried disabling hardware acceleration in the flash settings but saw no improvement. I have one last test to perform: install Firefox on her machine and test the VLC plug-in theory. I will report back this weekend with the findings.
Photo of

  • 2 Posts
  • 0 Likes
PROBLEM SOLVED

I had the same exact problem but I found the solution.

Do not use internet explorer.

I started my firefox and and went to hulu and now my videos are smooth, no choppiness no lagging.

By the way im using firefox version 2.0.0.2.0 with the latest flash player.
Photo of

  • 2 Posts
  • 1 Like
I have experienced the problems in IE as well as Firefox. I have also tested in Chrome and Safari and they also have the problems intermittently.

Also, Firefox 2 is old and subject to numerous security issues. You should consider updating.
Photo of

  • 16 Posts
  • 1 Like
@ least @ 12:36am Tuesday morning with 3.0.10 Firefox and 1024 screen resolution the short vid with "family guy" cast ran smoothly and i tested it on ep of "hell's kitchen" for 10 mins and that was smooth also. I would strongly recommend u upgrade firefox for the security fixes!
Photo of Michael VanderZand

Michael VanderZand

  • 1 Post
  • 0 Likes
I've tried Firefox 3, Firefox 3.6 Beta 1, Chrome, Opera, IE8, Lunascape 5, and Seamonkey. It is not a browser issue!
Photo of

  • 16 Posts
  • 1 Like
I have 3.0.8, and just got notification of a 3.0.10 which im about to install. Like Josh says u need 2 update your browser. Flash should be giving us a new version sooner rather than later...i hope.
Photo of

  • 2 Posts
  • 0 Likes
I just had an older version of firefox because I only use IE, but since this problem with hulu occured I decided to try firefox and it worked better than IE.

I upgraded firefox like you guys said and now it runs even more smoother!

Heres a couple tips for people to make hulu run smoother.

-Use the latest firefox dont use IE. IE + hulu + adobe flash dont get along well together.
-Upgrade to the latest adobe flash player
-When watching a movie pause the movie to allow it to buffer for smoother playback, and play in full screen with lights out.
Photo of

  • 1 Post
  • 0 Likes
Run Shockwave plugin this will correct the problem

http://get.adobe.com/shockwave/
Photo of caddenC

cadden

  • 1 Post
  • 0 Likes
Try disabling hardware acceleration in the settings on the flash player. I was having same issues and as soon as i unchecked that little box for hardware acceleration it works fine.
Photo of

  • 16 Posts
  • 1 Like
I'm sure we all did that. It's unchecked whenever I play Flash videos pd. It's been a bigger issue with how Flash player works with Hulu, because other websites' Flash videos are fine. I regularly check for Flash updates on Adobe, and Hulu says they are in communication with Adobe about the problem.
Photo of MartinM

Martin

  • 1 Post
  • 2 Likes
I had a P4 2.0GHz FSB400, 1GB ram, Geforce MX420 64MB.

Hulu at full screen was choppy and unwatchable.

Upgraded to a P4 2.8GHZ FSB533 and there was great improvement, but still a little choppy.

Changed Abode Flash setting to low quality and playback is fine.

Notes:

1. Check you CPU utilization (press Crtl-Alt-Del to bring up Task Manager and click on Performance tab). Needs to be less than 90%,

2. If it's more than 90%, try using lower quality settings in Adobe Flash Player (right mouse click on playback image to bring up menu). Personally I think the Hulu playback at full screen doesn't benefit from the higher settings.

3. Adobe Flash Player 10 hardware accelerator has issues with certain video cards. Try turning this off in the Adobe Flash Player menu (under settings).
Photo of Melissa Saint-Hilaire

Melissa Saint-Hilaire

  • 1 Post
  • 0 Likes
I tried every single option listed here and the only thing that worked was right clicking and changes the quality from high to low.

I'm a little bummed I can't watch it in high or medium, but at least I can watch Hulu without getting a headache now!
Photo of

  • 16 Posts
  • 1 Like
I think putting Flash player on low quality setting did it. I probably still have to pause to buffer some vids in general (i am on ovguide,com alot) but I should be getting a new Dell Hybrid sooner rather than later, so I won't be dealing with this 2001 Dell computer's CPU shortcomings. I have my screen resolution @ highest with flash on low qaulity. it's doing well and will trying out the vids @ different resolutions highter than 1280x....now i just have to go into my monitor controls and tweak how my font looks lol.
Photo of aneet84A

aneet84

  • 4 Posts
  • 0 Likes
Changing flash player to low quality didn't help either!!!!
Photo of meerakmasM

meerakmas

  • 1 Post
  • 4 Likes
The Symptoms and the solution!

I have the Dell D830, Dual CPU, 4 GB of memory plus a 19200X1200 running on XP Pro and with a 15 MB of download speed as per speedtest.net, it can certainly do many things at the same time not just Hulu stuff!

It was working fine on Hulu.com until about a year later in July 2009 when, and suddenly, decided to slow down!

Hulu in full screen mode would play but miserably!

First, I thought it must have been some software that I had downloaded. I kept removing and re-installing to no avail.

Then I thought, the best way would be to re-install the OS. I did, it worked fine for couple of weeks then, the same things started to happen.

My other laptop, Dell Inspiron, had no issues but it was running Vista Ultimate so, I decided to install the Vista on my D830 and hoping, may be, this would solve the issue. It did not!

So, I re-installed XP Pro coz I hate Vista's file manager and didn't see why I should keep it? I started downloading the latest drivers (Chipset, Video, Audio, etc.)...still, same problem!

Then I started googling the issue to see who else has it? Lo and behold, lots o of ppl were complaining and most offering advice here and there.

I tried them all, and nothing worked. Until I got to this page! I went thru the posts from top to bottom trying them all. None worked until I did Cliff's post where he recommended installing adobe shockwave:

http://get.adobe.com/shockwave/

I did and the problem went away! Go finger!!

Personally, I think it's the latest Adobe flash player causing the issue and installing the adobe shockwave reverses the issue some how.

Coz, it really can't be my hardware since it was working fine all along until they probably had updated the Adobe Player sometime in July (?)

I can't find any other reason?

So, go ahead...download the shockwave and let us know. You can't have it worse :)
Photo of lemmerotL

lemmerot

  • 1 Post
  • 0 Likes
I agree with meerakmas. Just downloaded and installed shockwave and my choppy fullscreen hulu video problem went away. Makes no sense, so I'm also agreeing that it was most likely a problem with the latest flash player update that shockwave somehow reverses. Gotta love the quality assurance!!!!
Photo of JeffJ

Jeff

  • 9 Posts
  • 0 Likes
Didn't do anything for me. Still choppy.
Photo of aneet84A

aneet84

  • 4 Posts
  • 0 Likes
Nice mate! Thanks... so far so good! Lets see if this charm continues though!