Adding a new title timeout and unresponsive

  • 2
  • Question
  • Updated 1 month ago
  • Answered
Every time I try to add a new title, the form page becomes unresponsive by the time I get to the bottom. Navigation completely stops working, and I am left to refresh and start over at the beginning, losing every data point I've entered. This is happened twice, and I'm starting to waste a lot of time on this. Is there a way around this very frustrating issue? I just want to add a title.
Photo of Andrew


  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 7 months ago

  • 2
Photo of Joel

Joel, Official Rep

  • 1222 Posts
  • 1723 Reply Likes
Hi Andrew,

Thanks for your post and sorry to hear you're experiencing issues with your new title.

We've not had any reports of problems on our new title submission forms - have you tried using another browser and/or computer to submit the title, if so does it present the same problem? 


Photo of Casey McKinnon

Casey McKinnon

  • 3 Posts
  • 2 Reply Likes
I've been getting this exact issue over the past day. I have tried changing browsers from Chrome, Chrome in Incognito Mode, and Safari. It clearly is not due to the browser. Has anyone else had this issue lately? Extremely frustrating as I have had to add the exact same info from scratch multiple times and every time it won't let me click Re-Check to add more info before saving. I have spent hours on this issue and I just don't know what to try next.