Firefox watchlist Strange characters or font

  • 1
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Old thread

When I login to my IMDB account to review my collection of movies, when i select a film and hit watchlist if I have the movie in question or see it, I'll see a strange character font listed beside the folder inquestion..  I am guessing this is because a font isn't being loaded or showed correctly.

It only does this in windows firefox, 4.0.0.3, it's been doing it for some time but now it's annoying me.

Only does it in firefox, chrome shows the character right.
Photo of jerry

jerry

  • 12 Posts
  • 11 Reply Likes

Posted 5 years ago

  • 1
Photo of DavidAH_Ca

DavidAH_Ca, Champion

  • 3263 Posts
  • 2925 Reply Likes
I assume you are talking about the green box to the left of "Yet to have watched".

On my system (Firefox 40.0.3) a green check mark is shown in that position if I have the film in that list.

A box with 4 characters in it is often shown when the system is unable to display a specific Unicode character, so I expect that is the problem here. This is strengthened by the fact that U+2714 is the code for ✔ HEAVY CHECK MARK.  The combination in the box, U+C114 섔 is deep in the Hangul area, so it would not be surprising if the font Firefox is using would not have the glyph available for display. (I have included the two characters in the text above. They show correctly for me;  are they both correct for you?)

The question then would be: Why is the code being changed from U+2714 to U+C114?

Unfortunately, I don't know how exactly to check this.  I will just note that in my Options |  Content I have the font specified as Times New Roman and under the Advanced button beside Font  I have also specified Ariel for Sans-serif and Courier New for Monospace  plus I have checked the box beside Allow pages to choose their own fonts, instead of my selections above
(Edited)
Photo of Nobody

Nobody

  • 1455 Posts
  • 707 Reply Likes
... Why is the code being changed from U+2714 to U+C114?
If you zoom-in on the image and take a close look, you can see evidence that the code's first digit is really a 2 with the top cut-off, and the second digit is a 7 with the top cut-off (obscured by the top border of the box).  So, the code is 2714, which as you say is the code for the heavy check-mark.
(Edited)
Photo of DavidAH_Ca

DavidAH_Ca, Champion

  • 3263 Posts
  • 2925 Reply Likes
I checked the pic as shown, and clicked to get the original (which was smaller) but did not download it to a separate image viewer, and I did not see that.

This makes more sense. Thanks for the correction.
Photo of Nobody

Nobody

  • 1455 Posts
  • 707 Reply Likes
If you right-click on that square green box and select "Inspect Element", you can then use the element inspector's "Rules" tab to see if the correct font (probably Verdana) is specified in CSS for that element, and you can use the "Computed" tab to verify that the specified font has been assigned to the element.

I wonder if a browser add-on could cause the problem?  You can try disabling your installed extensions, or you can restart Firefox in its "safe mode".  If the character is correctly displayed when extensions are disabled, then you can investigate to find out which extension may have caused the problem.
Photo of DavidAH_Ca

DavidAH_Ca, Champion

  • 3263 Posts
  • 2925 Reply Likes
I wonder if perhaps they don't have the Allow pages to choose their own fonts, instead of my selections above box checked.
It seems to me that that could cause the problem if their chosen fonts don't have the appropriate glyph.

That is why I mentioned it in my previous post.
(Edited)
Photo of Nobody

Nobody

  • 1455 Posts
  • 707 Reply Likes
If I may ask, what version of Windows are you using?
Is your Windows system fully up-to-date
with all applicable service packs and updates?

This conversation is no longer open for comments or replies.