I understand the need to advertise, but...

  • 1
  • Problem
  • Updated 4 months ago
  • Solved
I love IMDB, I promote it every time someone talks about a movie.  I do understand the need for advertising to remain free, but when I get the same pop up after every click, for the top movies that I see everywhere else, is getting so annoying to the point that I'm thinking of changing movie info sites.
  Set it up like other sites where after so many clicks the pop up's stop appearing so I'm not constantly closing the same thing every click!!
Photo of Shawn Sweetland

Shawn Sweetland

  • 2 Posts
  • 1 Reply Like

Posted 4 months ago

  • 1
Photo of Steve

Steve, Employee

  • 911 Posts
  • 481 Reply Likes
Hi Shawn,

We use a cookie-based system to limit the number and type of ads that are displayed to our users in each session, so I would recommend configuring your browser to ensure you are accepting cookies from IMDb. For more information on ads and the best ways to prevent repetition, please see:

https://help.imdb.com/article/imdb/general-information/can-you-get-rid-of-the-ads-on-your-site/GDXHL...

If you have tried the above and are still noticing the same ad repeated, please write us back with a description of the specific ad so we can investigate further.

Thanks in advance!

- Steve
(Edited)
Photo of Col Needham

Col Needham, Official Rep

  • 6030 Posts
  • 3055 Reply Likes
In addition to Steve's reply above, please note that ironically, ad / cookie blocking plug-ins can interfere with the frequency capping itself so if you try disabling any ad blockers, everything should work as expected. 

If this does not fix it, have you selected the option "Do Not Personalize Ads from Amazon for this Internet Browser" on https://www.amazon.com/adprefs ? By selecting this option, Amazon would not apply frequency capping on your requests, and this would explain the behaviour since you are essentially opting out of us storing any information, including whether or not you have already seen the ad.
Photo of Shawn Sweetland

Shawn Sweetland

  • 2 Posts
  • 1 Reply Like
Well that seems to be the issue, I had just installed System Mechanic Pro, and it cleared and blocked cookies.  All good now...Thank you for the prompt replies!!   Shawn.