IMDb Default Language

  • 2
  • Question
  • Updated 3 months ago
  • Answered
Whenever I open the IMDb pages, movie titles are displayed in Turkish instead of English. I don't get this. Yes I'm ethnically Turkish, but

- I live in NY
- I connect through the local internet obviously, meaning my IP address is from NY
- My computer is purchased in NY
- My OS (Windows) and browser (Chrome) are set for English language
- Even my Amazon account (in case they link in the background) is in English

I have NOTHING in Turkish - how is IMDb picking up Turkish when I open their page? I really don't get it. I know you can change your settings if you open up an account etc., but I want to understand what's happening.

Anyone has any ideas?
Photo of Cagatay Gulec

Cagatay Gulec

  • 1 Post
  • 0 Reply Likes

Posted 3 months ago

  • 2
Photo of Jeorj Euler

Jeorj Euler

  • 6578 Posts
  • 8125 Reply Likes
Possibilities:
  • The WHOIS information associated with the Internet address could be out of date.
  • Particular settings for proxy or virtual private network could be involved.
  • Being mistaken about the browser language settings.
There are websites that will indicate to a visitor thereto what the the applicable Internet address and HTTP request headers are or appear to be.
Photo of Vincent Fournols

Vincent Fournols

  • 2901 Posts
  • 4837 Reply Likes
Cagatay,

On top of Jeorj's suggestions, what are your country and language settings in your IMDb account?
Photo of Ed Jones (XLIX)

Ed Jones (XLIX)

  • 10962 Posts
  • 12407 Reply Likes
Go Here.
https://www.imdb.com/preferences/general

Is it set to these parameters?
If not, set them to the same exact settings and select submit




Photo of MAthePA

MAthePA

  • 1324 Posts
  • 2235 Reply Likes
Hi, Cagatay Gulec.

I'd like to emphasis what Jeorj Euler has pointed above.
You may be mistaken about the browser language settings. In your browser, please check:
Advanced settings => Languages
If the list of languages starts with the language that is automatically used for the IMDb lists, you have to move English to the very top of the languages list. That's it.