submitted review gets stuck

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
Hi, I seem to have a problem with submitting a review with reference 130813-055608-689000. Although older and more recent submitted reviews pass, this one seems to get stuck in traffic. Posted it 15 days ago (130801-075653-856000), nothing happened, and again a few days ago but without success. Thanks for the help!
Photo of Bob Joosen

Bob Joosen

  • 14 Posts
  • 1 Reply Like

Posted 6 years ago

  • 1
Photo of Bob Joosen

Bob Joosen

  • 14 Posts
  • 1 Reply Like
Is anybody from the staff reading this forum or is this just for show?
Photo of Emperor

Emperor, Champion

  • 6418 Posts
  • 3004 Reply Likes
Staff do read the board, although it is possible a few are on the Summer holidays, so the response might be slower. They are also less active on weekends, so you might get a reply from them in a day or so.
Photo of Bob Joosen

Bob Joosen

  • 14 Posts
  • 1 Reply Like
ok, good to know. I will wait some more.
Photo of Bob Joosen

Bob Joosen

  • 14 Posts
  • 1 Reply Like
Still no answer? What the hell? Is anybody going to addresse this issue?
Photo of Peter

Peter, Champion

  • 6267 Posts
  • 7485 Reply Likes
Can you tell us which title this was for and how you formatted the submission? Then someone other than staff may be able to help.
Photo of Michelle

Michelle, Official Rep

  • 12506 Posts
  • 9206 Reply Likes
Hi Bob -

I looked at the updates you referenced and I observed that you did not include the name of the reviewer, which is likely why your External Review wasn't processed.

You will need to correct the Description format so that it includes the following:

WebsiteName [ReviewerName] (Language if not English)